** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - ADO y  SQL AZURE
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoADO y SQL AZURE

 Responder Responder
Autor
Mensaje
larry83 Ver desplegable
Nuevo
Nuevo


Unido: 03/Agosto/2015
Localización: Sevilla
Estado: Sin conexión
Puntos: 5
Enlace directo a este mensaje Tema: ADO y SQL AZURE
    Enviado: 05/Agosto/2015 a las 12:44
Buenos días,

Estoy intentando realizar una conexión de un formulario con mi base de datos Azure.
He hecho la prueba con MZ Tools y me conecta perfectamente, pero luego pongo el código y me sale este error.

" Error de compilacion, se esperaba un tipo definido por el usuario no un proyecto.

Dim Conexion As New ADODB


Conexion.ConnectionString = "Provider=SQLNCLI11.1;" _
& "Integrated Security="";" _
& "Persist Security Info=False;" _
& "User ID=Usuario;" _
& "Initial Catalog=BaseDatos;" _
& "Data Source=aaikjeo9a9.database.windows.net;" _
& "Initial File Name="";" _
& "Server SPN = "";"

Conexion.Open



A que se debe el error?
Cuando uso MZ Tools le meto la contraseña, pero luego cuando me lo copia al portapepeles no aparece,  tendrñia que ponerla yo'?

como & "Password= Clave";






Arriba
larry83 Ver desplegable
Nuevo
Nuevo


Unido: 03/Agosto/2015
Localización: Sevilla
Estado: Sin conexión
Puntos: 5
Enlace directo a este mensaje Enviado: 05/Agosto/2015 a las 12:59

Había olvidado poner Conecction y ahora me sale este error:

"El formato de la cadena de inicializacion no cumple con la especificacion OLE DB"


Dim Conexion As New ADODB.Connection


Conexion.ConnectionString = "Provider=SQLNCLI11.1;" _
& "Integrated Security="";" _
& "Persist Security Info=False;" _
& "User ID=Usuario;" _
& "Initial Catalog=BaseDatos;" _
& "Data Source=aaikjeo9a9.database.windows.net;" _
& "Initial File Name="";" _
& "Server SPN = "";"

Conexion.Open
Arriba
Chea1 Ver desplegable
Moderador
Moderador


Unido: 20/Noviembre/2005
Localización: España
Estado: Sin conexión
Puntos: 4069
Enlace directo a este mensaje Enviado: 06/Agosto/2015 a las 09:15
Hace mucho que no uso ADO, pero veo que, al hacer la concatenación, en la cadena resultante tanto Integrate Security como Initial File Name son igual a una sola comilla simple.
 
 
Saludos
José Bengoechea Ibaceta
Mi página

Mi otra página
Arriba
larry83 Ver desplegable
Nuevo
Nuevo


Unido: 03/Agosto/2015
Localización: Sevilla
Estado: Sin conexión
Puntos: 5
Enlace directo a este mensaje Enviado: 06/Agosto/2015 a las 13:47
que va, si quitas las comillas y dejas una simple te sale error, no te deja.
Tienes que ser las 2 si o si.
El problema es que eso es lo que me sale con MZ tools  y conecta, pero cuando pongo el codigo no conecta y soy incapaz de ver el fallo.
Arriba
Chea1 Ver desplegable
Moderador
Moderador


Unido: 20/Noviembre/2005
Localización: España
Estado: Sin conexión
Puntos: 4069
Enlace directo a este mensaje Enviado: 06/Agosto/2015 a las 15:30
Perdona. Quise decir una sola comilla doble, normalmente van a pares.
Saludos
José Bengoechea Ibaceta
Mi página

Mi otra página
Arriba
Mihura Ver desplegable
Administrador
Administrador
Avatar

Unido: 06/Mayo/2005
Localización: En la dehesa
Estado: Sin conexión
Puntos: 11005
Enlace directo a este mensaje Enviado: 06/Agosto/2015 a las 17:31
Copiado de una aplicación:


    CnRemota.ConnectionString = "Provider=SQLNCLI11.1;Integrated Security=;Persist Security Info=False;User ID=loginUsuario;Pwd=MiContraseña;Initial Catalog=CatalogoInicial;Data Source=xxxxxxxx.database.windows.net;Initial File Name=;Server SPN="
    CnRemota.Properties("Current Language") = "spanish"
    CnRemota.Open



Quita a tu cadena todas las concatenaciones que tiene.




Editado por Mihura - 06/Agosto/2015 a las 17:32
Jesús Mansilla Castells.
Saludos desde Móstoles.

Access Aplicaciones
Tecsys.es
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable