** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - Antes no me daba error
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Antes no me daba error

 Responder Responder
Autor
Mensaje
Jose35 Ver desplegable
Habitual
Habitual


Unido: 05/Noviembre/2017
Localización: Aljaraque
Estado: Sin conexión
Puntos: 83
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Jose35 Cita  ResponderRespuesta Enlace directo a este mensaje Tema: Antes no me daba error
    Enviado: 02/Julio/2019 a las 12:24
Buenas, desde que he cambiado a Access 2016 y he partido la base de datos en Front-end /Back-end el programa se me para en la siguiente línea, si le doy a continuar en editor de VBA, continua sin problemas, pero porque se para ahí.

la línea en concreto en la que se para es:

Forms!frmModeloProvisión![Ubicacion2] = ubica2


y esta dentro de este ElseIF, la voy a separar un poco para que la veais mejor;


ElseIf a = 4 Then
Forms!frmModeloProvisión![Ubicacion2].Visible = True
Forms!frmModeloProvisión![Ubicacion3].Visible = True
Forms!frmModeloProvisión![Ubicacion4].Visible = True
.MoveNext
ubica2 = !Ubicacion
actua2 = !Numero_Actuacion
estad2 = !estado



Forms!frmModeloProvisión![Ubicacion2] = ubica2



.MoveNext
ubica3 = !Ubicacion
actua3 = !Numero_Actuacion
estad3 = !estado
Forms!frmModeloProvisión![Ubicacion3] = ubica3
.MoveNext
ubica4 = !Ubicacion
actua4 = !Numero_Actuacion
estad4 = !estado
Forms!frmModeloProvisión![Ubicacion4] = ubica4


antes no se paraba ni daba error, ¿porqué ahora si?.

Saludos.

Arriba
Mihura Ver desplegable
Administrador
Administrador
Avatar

Unido: 06/Mayo/2005
Localización: En la dehesa
Estado: Sin conexión
Puntos: 10973
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Mihura Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 02/Julio/2019 a las 16:07
Dices que le das a continuar y sigue sin problemas ¿no? ... ¿has tenido un punto de interrupción ahí? a veces Access hace cosas raras con los mismos.

Corta la línea y vuelve a pegarla, verás como se soluciona (si es ese el error).


Jesús Mansilla Castells.
Saludos desde Móstoles.

Access Aplicaciones
Tecsys.es
Arriba
Maverick2019 Ver desplegable
Nuevo
Nuevo


Unido: 10/Junio/2019
Localización: Madrid
Estado: Sin conexión
Puntos: 26
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Maverick2019 Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 04/Julio/2019 a las 09:40
Hola ¿tienees algúna línea de ON ERROR? ¿Como la tienes configurada?

Salu2,
Arriba
Jose35 Ver desplegable
Habitual
Habitual


Unido: 05/Noviembre/2017
Localización: Aljaraque
Estado: Sin conexión
Puntos: 83
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Jose35 Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 04/Julio/2019 a las 22:12
Perdonar por tardar en responder, ando muy liado en el curro estoy solo y no puede casi ponerme a modificar la BD. Ayer dije que le daba a continuar y continuaba, es verdad que continúa pero no hace todo el proceso. Sin embargo le vuelvo a dar po 2 vez al botón y ahora si lo finaliza sin error.

Mihura!!, corte y pegue la linea tal y como me indicaste y sigue igual, no se ha solucionado.

Por cierto Maverick no tengo configurada rutina o líneas de error en este Sub.

Editado por Jose35 - 05/Julio/2019 a las 07:13
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable