** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - AutoKeys
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

AutoKeys

 Responder Responder
Autor
Mensaje
main Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 31/Agosto/2009
Localización: OVIEDO
Estado: Sin conexión
Puntos: 1034
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita main Cita  ResponderRespuesta Enlace directo a este mensaje Tema: AutoKeys
    Enviado: 05/Noviembre/2019 a las 11:49
Access_2010 vs Windows_7
Buenos dias al Grupo
He creado la macro AutoKeys con varias submacros, todas ellas con la misma estructura, como la siguiente:
____________________________
Submacro  ^S
AbrirFormulario
NombreFormulario    Servicios
Vista  Formulario
-------------------
-------------------
Modo de la ventana     Normal
Finalizar submacro
_____________________________
Pero me encuentro con que no se ejecuta ninguna de ellas cuando pulso ctrl + letra.
En cambio si me situo en la barra de navegacion sobre la macro Autokeys y pulso intro, me ejecuta la primera de las submacros.
En access_2003 funcionaban correctamente y no se si habrá que actualizar en access_2010 algún parametro de las Opciones de access.
Saludos cordiales para todos.

Arriba
mounir Ver desplegable
Colaborador
Colaborador


Unido: 09/Febrero/2009
Localización: Asturias-España
Estado: en línea
Puntos: 5274
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita mounir Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 05/Noviembre/2019 a las 15:57
Hola!

Creo que el problema está en la tilde "^S" escríbelo de nuevo.

Editado por mounir - 05/Noviembre/2019 a las 21:52
Un Saludo.
Arriba
main Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 31/Agosto/2009
Localización: OVIEDO
Estado: Sin conexión
Puntos: 1034
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita main Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 05/Noviembre/2019 a las 19:47
Hola mounir, me temo que no es ese el problema.
He cambiado ^S por "^S" y sigue haciendo exactamente lo mismo.
Gracias y un saludo
Arriba
Mihura Ver desplegable
Administrador
Administrador
Avatar

Unido: 06/Mayo/2005
Localización: En la dehesa
Estado: Sin conexión
Puntos: 11167
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Mihura Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 05/Noviembre/2019 a las 20:35
Con ^C funciona bien

- para obtenerlo pulsa shift y sin soltar tecla circunflejo y la C
Jesús Mansilla Castells.
Saludos desde Móstoles.

Access Aplicaciones
Tecsys.es
Arriba
main Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 31/Agosto/2009
Localización: OVIEDO
Estado: Sin conexión
Puntos: 1034
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita main Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 05/Noviembre/2019 a las 21:30
Nada, que si quies arroz arroz catalina
Gracias Mihura, probaré en otro PC por si estuviera mal mi teclado.
Pero desde luego, que yo no noto nada raro en el mio
Saludos
Arriba
main Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 31/Agosto/2009
Localización: OVIEDO
Estado: Sin conexión
Puntos: 1034
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita main Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 06/Noviembre/2019 a las 10:24
Buenos dias, jovenes
He probado desde el de casa además de otros dos del despacho, incluso con otros ejemplos de otros compañeros que incluyen la macro Autokeys y no furrula.
En cambiio, en todos reconoce el teclado. Si pulso Ctrl+A me abre el cuadro de Abrir archivo y si pulso Ctrl+P depende donde me encuentre en el panel de navegación. Si estoy en la sección de macros me abre un cuadro para imprimir la definición de macros y si estoy en otrs seciones(Tablas o consultas) me abre el cuadro de imprimir.
En fin, que no entiendo nada
Yo que ya soy bastante reacio a las macros, solo uso autoexec y no siempre.
A ver si se os ocurre algo antes de desistir de la puñe--ra macro.

Gracias Mihura
Saludos a todos
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable