** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - Columna selectiva
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoColumna selectiva

 Responder Responder
Autor
Mensaje
marioboss Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 19/Mayo/2005
Localización: España
Estado: Sin conexión
Puntos: 452
Enlace directo a este mensaje Tema: Columna selectiva
    Enviado: 15/Diciembre/2009 a las 09:31

Hola a todos.

Os cuento. Tengo como origen las columnas Nivel y Datos y lo que pretendo es construir la columna Objetivo, en la cual tendría que aparecer el valor de la columna Datos desde que en la columna Nivel haya un 4 hasta el siguiente 4. Espero que el ejemplo sea aclaratorio.

Muchas gracias por la ayuda y un saludo.

Nivel Datos Objetivo
  4A     A
  5B     A
  5C     A
  5D     A
  4E     E
  5F     E
  5G     E
  4H     H
  5I      H
  5J      H
  5K     H

 
 
 
Editado (AnSanVal): Para quitar códigos de Word.


Editado por AnSanVal - 15/Diciembre/2009 a las 10:48
"Solo hay dos cosas infinitas en la vida, una el universo y la otra la estupidez de los humanos, aunque de la primera no estoy seguro del todo."Albert Einstein.Saludos a todos los foreros.
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5511
Enlace directo a este mensaje Enviado: 15/Diciembre/2009 a las 11:09

La consulta no está suficientemente clara, ya que no has incluido en objetivo como quieres que te quede.

Suponiendo los datos en A1:C12 (títulos en fila 1), mira si lo que quieres es una de las siguientes opciones.

Opción 1.
1.- [C2]     =SI(ESERROR(ENCONTRAR(4;A2));"";B2)
2.- Copia/Pega C2 hasta C12

Opción 2.
1.- [C2]     =SI(ESERROR(ENCONTRAR(4;A2));"";B2)
2.- [C3]     =SI(ESERROR(ENCONTRAR(4;A3));C2;B2)
3.- Copia/Pega C3 hasta C12

Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
marioboss Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 19/Mayo/2005
Localización: España
Estado: Sin conexión
Puntos: 452
Enlace directo a este mensaje Enviado: 15/Diciembre/2009 a las 11:38
Nivel   Datos   Objetivo
4   A   A
5   B   A
5   C   A
5   D   A
4   E   E
5   F   E
5   G   E
4   H   H
5   I   H
5   J   H
5   K   H
"Solo hay dos cosas infinitas en la vida, una el universo y la otra la estupidez de los humanos, aunque de la primera no estoy seguro del todo."Albert Einstein.Saludos a todos los foreros.
Arriba
marioboss Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 19/Mayo/2005
Localización: España
Estado: Sin conexión
Puntos: 452
Enlace directo a este mensaje Enviado: 15/Diciembre/2009 a las 15:33
Muchas gracias Antonio.

Es casi exactamente lo que quería con una pequeña modificación:

Opción 2.
1.- [C2]     =SI(ESERROR(ENCONTRAR(4;A2));"";B2)
2.- [C3]     =SI(ESERROR(ENCONTRAR(4;A3));C2;B3)
3.- Copia/Pega C3 hasta C12
"Solo hay dos cosas infinitas en la vida, una el universo y la otra la estupidez de los humanos, aunque de la primera no estoy seguro del todo."Albert Einstein.Saludos a todos los foreros.
Arriba
marioboss Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 19/Mayo/2005
Localización: España
Estado: Sin conexión
Puntos: 452
Enlace directo a este mensaje Enviado: 15/Diciembre/2009 a las 15:34
Perdón, se me olvidaba decir que tema cerrado.

Muchas gracias.
"Solo hay dos cosas infinitas en la vida, una el universo y la otra la estupidez de los humanos, aunque de la primera no estoy seguro del todo."Albert Einstein.Saludos a todos los foreros.
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable