** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - Condicional matricial
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoCondicional matricial

 Responder Responder
Autor
Mensaje
alfare Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 28/Junio/2006
Localización: Colombia
Estado: Sin conexión
Puntos: 605
Enlace directo a este mensaje Tema: Condicional matricial
    Enviado: 26/Mayo/2013 a las 03:29
Hola a todos amigos de Excel , por favor me colaboran con una duda que tengo...en la columna R necesito formula un condicional que me determine el proveedor con el menor valor total , de acuerdo a este ejemplo el menor valor total es 30 y el proveedor que lo tiene es el #2. En la columna Q utilice una formula matricial que toma unos valores que estan ocultos en la fila 3 ( ver barra de formula ) , sin embargo estoy corto para formular el condicional de la colomna R , :-(.
alguna sugerencia?? de antemano gracias



Editado por alfare - 26/Mayo/2013 a las 03:30
Slds desde Cali Colombia
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5511
Enlace directo a este mensaje Enviado: 26/Mayo/2013 a las 11:56
 

Hola Alfare.

 
Si los valores que están ocultos en:  D2 (desconozco la fila), G2, J2, M2 ó P2 no van a coincidir nunca con Q2 Prueba con:
 

[R2]   =COINCIDIR(Q2;A2:O2;0)/3

 
 
Ten en cuenta que si el valor buscado coincide en  mas de un vendedor, devolverá el primero.
 
Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5511
Enlace directo a este mensaje Enviado: 26/Mayo/2013 a las 12:04
Si no tienes que ralizar operaciones de cálculo con el valor devuelto en R2, podrias utilizar ...
 
=COINCIDIR(Q2;A2:O2;0)/3 & " (" &CONTAR.SI(A2:O2;Q2) & ")"
 
... que indica entre paréntesis los vendedores que han obtenido ese "menor valor"*.
 
 
 
* Realmente (en tu ejemplo) no es el menor ya que en O2 hay un cero.
 
Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
alfare Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 28/Junio/2006
Localización: Colombia
Estado: Sin conexión
Puntos: 605
Enlace directo a este mensaje Enviado: 26/Mayo/2013 a las 20:53
hola Ansanval

=SI(C2=Q2;B1;(SI(F2=Q2;E1;(SI(I2=Q2;H1;(SI(L2=Q2;K1;(SI(O2=Q2;N1;"")))))))))

Hoy me levante mas despejado y logre diseñar la formula que necesitaba!!...sin embargo sus sugerencias las aprecio mucho como siempre , mil gracias.

podes cerrar el hilo.
Slds desde Cali Colombia
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable