** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - Convertir formato de fecha (mes) a ingles
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoConvertir formato de fecha (mes) a ingles

 Responder Responder
Autor
Mensaje
TweeK Ver desplegable
Nuevo
Nuevo


Unido: 15/Agosto/2008
Localización: Panama
Estado: Sin conexión
Puntos: 0
Enlace directo a este mensaje Tema: Convertir formato de fecha (mes) a ingles
    Enviado: 19/Mayo/2009 a las 05:14
Buenas:
 
En una columna tengo el mes en español y nececito pasarlo al formato en inglés y numérico. En el siguiente ejemplo, aparece en la columna A como lo tengo y, en las columnas B y c como espero convertirlo:
 
A B C
Mes Month Mes
Enero Jan 1
Enero Jan 1
Enero Jan 1
Febrero Feb 2
Febrero Feb 2
Febrero Feb 2
Febrero Feb 2
Marzo Mar 3
Marzo Mar 3
Marzo Mar 3
Marzo Mar 3
 
 
espero que me puedan apoyar, mi excel está en español,
 
Saludos,
IDO
Arriba
JOSE LUIS CALVO Ver desplegable
Habitual
Habitual
Avatar

Unido: 30/Diciembre/2008
Localización: Colombia
Estado: Sin conexión
Puntos: 141
Enlace directo a este mensaje Enviado: 19/Mayo/2009 a las 05:55
Una opción que se me ocurre para solucionar tu problema es que hagas algo como una tabla de conversión así:
 
             A                            B                        C
 1     Mes Español           Mes Inglés         Mes Numérico
 2     Enero                      January              1
 3     Febrero                   February             2
 4     Marzo                      March                 3
 5     ..........etc...
 ....
 12   Diciembre                December           12
 
Ahora donde quieras pasarlo vas a utilizar la función BuscarV. Por ejemplo
 
             A                            B                         C
30    Febrero
 
En la celda "B30", colocarías algo como =buscarv(a30;$a$1:$c$12;2;0)
En la celda "C30", colocarías algo como =buscarv(a30;$a$1:$c$12;3;0)
 
Recuerda que el rango $a$1:$c$12 indica que tienes tales celdas con la información de todos los meses que necesitas.
 
Y luego ya puedes copiar la fórmula y arrastrarla hacia abajo hasta donde la necesites.
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5440
Enlace directo a este mensaje Enviado: 19/Mayo/2009 a las 12:03
 

Otra opción (sin listas aparte):

 

[C2]  =COINCIDIR(A2;{"Enero"\"Febrero"\"Marzo"\"Abril"};0)

[B2]  =INDICE({"Jan"\"Feb"\"Mar"\"Apr"};C2)

 
 
Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
TweeK Ver desplegable
Nuevo
Nuevo


Unido: 15/Agosto/2008
Localización: Panama
Estado: Sin conexión
Puntos: 0
Enlace directo a este mensaje Enviado: 20/Mayo/2009 a las 19:21
Ok, resuelto.
 
 
muchas gracias,
 
Iván
IDO
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable