** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - Cuadro de texto no aparece hasta hacer click
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Cuadro de texto no aparece hasta hacer click

 Responder Responder
Autor
Mensaje
Ajito Ver desplegable
Habitual
Habitual


Unido: 31/Enero/2020
Localización: Las Palmas
Estado: Sin conexión
Puntos: 63
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Ajito Cita  ResponderRespuesta Enlace directo a este mensaje Tema: Cuadro de texto no aparece hasta hacer click
    Enviado: 30/Diciembre/2020 a las 13:00
Buenas compañer@s

Ayer hice una consulta similar a esta que, como siempre lograron solucionarme, pero ahora quiero agregar una cosa mas, pero me esta dando la lata otra cosa.--

Estoy con un Informe que me agrupa calles segun el distrito que pertenezcan. Mi objetivo es que en el encabezado de cada agrupamiento me salga el nombre del distrito en cuestión (eso me lo solucionaron ayer) pero ahora pretendo que junto al nombre del distrito me cuente la cantidad de calles que corresponden a ese distrito.

Por ejemplo: Distrito Centro (10)

Después de investigar logro esta sintaxis que hace lo que pretendo

="Distrito " & [Distrito] & " (" & Cuenta([Codigo]) & ")"

Cuando ya "canto victoria" de que lo he conseguido, resulta que cuando voy a visualizar el informe de forma "normal" ... no aparece nada.





Pero si hago click en el lugar donde deberia ir, entonces si aparece:




Al imprimir aparece también sin problemas. Pero en pantalla, es como que aparece oculto". He mirado en las propiedades y lo tengo "Mostrar Cuando" en Siempre.

La verdad, no sé que más comprobar.

Un saludo y gracias por adelantado.





Editado por Ajito - 30/Diciembre/2020 a las 13:06
Arriba
xavi Ver desplegable
Administrador
Administrador
Avatar
Terrassa-BCN

Unido: 10/Mayo/2005
Localización: Catalunya ||||
Estado: Sin conexión
Puntos: 13553
Opciones de entrada Opciones de entrada   Gracias (1) Gracias(1)   Cita xavi Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 30/Diciembre/2020 a las 13:42
Hola,

Como algunos ya saben, los informes y yo no somos demasiado amigos. Pero ese problema no solo lo he detectado en los informes; a veces también en algún formulario.

Mi solución es utilizar un evento para realizar la asignación por código del caption de una etiqueta.

Un saludo

Xavi, un minyó de Terrassa

Mi web
Arriba
Ajito Ver desplegable
Habitual
Habitual


Unido: 31/Enero/2020
Localización: Las Palmas
Estado: Sin conexión
Puntos: 63
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Ajito Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 31/Diciembre/2020 a las 13:11
Publicado originalmente por xavi xavi escribió:

Hola,

Como algunos ya saben, los informes y yo no somos demasiado amigos. Pero ese problema no solo lo he detectado en los informes; a veces también en algún formulario.

Mi solución es utilizar un evento para realizar la asignación por código del caption de una etiqueta.

Un saludo



La verdad que los informes son un poco puñeteros a veces.

Voy a probar tu solución. Gracias!
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable