** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - Diferencia fechas
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoDiferencia fechas

 Responder Responder
Autor
Mensaje
koldo Ver desplegable
Habitual
Habitual
Avatar

Unido: 12/Febrero/2008
Estado: Sin conexión
Puntos: 53
Enlace directo a este mensaje Tema: Diferencia fechas
    Enviado: 21/Enero/2019 a las 20:30
Hola A todos,

Me gustaría saber sí hay alguna forma de calcular las horas entre dos fechas en la que no me cuente unas horas determinadas de la primera Fecha,
Se trata de que no cuente las horas que sean mayor a las 20:00 y menor de las 8:00 del día siguiente de la fecha inicial:


Finicio FFin Horas
09/10/2018 1:58 09/10/2018 9:28 1:28
08/10/2018 20:30 09/10/2018 9:28 1:28


Gracias
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5454
Enlace directo a este mensaje Enviado: 22/Enero/2019 a las 13:31

(Casi) siempre hay alguna forma.


Debes convertir las horas en sus «horas límite» correspondientes, por ejemplo en columnas auxiliares (que puedes ocultar), y luego si el día es el mismo para INICIO y FIN; es una simple resta y si son días diferentes; sumas las horas del primer día más las del segundo (estoy considerando que son días consecutivos [p.e. día 8 y día 9]), si hay días completos intermedios deberás sumar además la(s) jornada(s) correspondiente(s).


Tambien podrías hacerlo con una UDF (función definida por el usuario), depende si estás 'suelto' en programación VBA.




>>> Regreso, para editar e incluirte (como ejemplo) la fórmula para la «hora límite» de FInicio:

[A2]   09/10/2018  1:58

[J2]   =MAX(A2;ENTERO(A2)+"8:00")     (columna auxiliar 1)

[K2]   =MIN(J2;ENTERO(A2)+"20:00")     (columna auxiliar 2)  (fecha/hora para los cálculos)


L y M serían columna auxiliar 3  y columna auxiliar 4, para FFin.



Editado por AnSanVal - 22/Enero/2019 a las 14:19
Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
koldo Ver desplegable
Habitual
Habitual
Avatar

Unido: 12/Febrero/2008
Estado: Sin conexión
Puntos: 53
Enlace directo a este mensaje Enviado: 22/Enero/2019 a las 22:29
Hola Gracias por responder
Con la idea que me has dado al final he hecho lo siguiente

[A2] 09/10/2018 1:58
[B2] 10/10/2018 15:30
[C2] =SI(A2>ENTERO(A2)+"20:00";ENTERO(B2)+"8:00";A2) (columna auxiliar 1)
[D2] =SI(C2<ENTERO(C2)+"8:00";ENTERO(C2)+"8:00";C2)   (columna auxiliar 2,  fecha/hora para los cálculos)


Mil gracias por el aporte

por mi parte se puede cerrar este tema

Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable