** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - Error con buscarv
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoError con buscarv

 Responder Responder
Autor
Mensaje
enetovb6 Ver desplegable
Habitual
Habitual
Avatar

Unido: 04/Mayo/2005
Localización: Peru
Estado: Sin conexión
Puntos: 104
Enlace directo a este mensaje Tema: Error con buscarv
    Enviado: 04/Septiembre/2009 a las 18:05
Hola a todos, estoy utilizando buscarv en una celda de la hoja2
y esta es mi formula
 
=SI(Hoja2!$C$13="P1",BUSCARV((Hoja2!A1),Hoja1!$A$1:$L$13,2),SI(Hoja2!$C$13="P2",BUSCARV(Hoja2!A1,Hoja1!$A$1:$L$13,3),SI(Hoja2!$C$13="P3",BUSCARV(+Hoja2!A1,Hoja1!$A$1:$L$13,4))))
 
 
Tengo esta tabla en la hoja1 (la tabla tiene mas columnas)
 
Enero 324.58
Febrero 370.81
Marzo 299.77
Abril 132.96
Mayo 72.09
Junio 37.15
Julio 36.88
Agosto 41.17
Septiembre 50.66
Octubre 70.20
Noviembre 98.55
Diciembre 214.23
 
el resultado es este
 
 
Enero 324.58
Febrero 370.81
Marzo 41.17
Abril #N/A
Mayo 41.17
Junio 37.15
Julio 132.96
Agosto #N/A
Septiembre 50.66
Octubre 41.17
Noviembre 41.17
Diciembre        #N/A 
 
Porque me sale 41.17 en MArzo cuando deberia ser 299.77 y N/A en las otras celdas? A parte utilizao la funcion SI para una seleccion pero no veo el error.
 
Gracias
 
 
neto
Arriba
sailepaty Ver desplegable
Asiduo
Asiduo


Unido: 23/Junio/2006
Localización: Estados Unidos
Estado: Sin conexión
Puntos: 458
Enlace directo a este mensaje Enviado: 04/Septiembre/2009 a las 18:14
Tu error esta en no utilizar el ultimo parametro de la función BUSCARV. Puedes simplificar tu formula de esta manera.
 
=BUSCARV(A1,Hoja1!$A$1:$L$13,DERECHA($C$13,1)+1,0)
 
Saludos
Arriba
enetovb6 Ver desplegable
Habitual
Habitual
Avatar

Unido: 04/Mayo/2005
Localización: Peru
Estado: Sin conexión
Puntos: 104
Enlace directo a este mensaje Enviado: 04/Septiembre/2009 a las 18:32
gracias.
neto
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable