** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - error de access, no funciona nada
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoerror de access, no funciona nada

 Responder Responder
Autor
Mensaje
arcangelcaos Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 15/Noviembre/2012
Localización: España
Estado: Sin conexión
Puntos: 236
Enlace directo a este mensaje Tema: error de access, no funciona nada
    Enviado: 21/Septiembre/2015 a las 14:10
Hola, tengo un ordenador rebelde.
Cuando le copio la BD esta deja de funciona, ningún código VB funciona, ni siquiera las macros.
La expresión "Al hacer click" que ha especificado como valor de la propiedad de evento produjo un error

Ese es el mensaje con mas texto.
La cosa es que esa misma base de datos en otros ordenadores funcionas.
Y peor aún, si abro en modo diseño la base de datos, accedo a cualquier formulario en diseño, entro al vb y luego salgo. Funciona todo bien, sin fallos, es si abro directamente.

Estoy desesperado. La cosa es que funcionaba bien.

Gracias.
Arriba
jilo Ver desplegable
Colaborador
Colaborador


Unido: 19/Diciembre/2004
Localización: TAFALLA
Estado: Sin conexión
Puntos: 850
Enlace directo a este mensaje Enviado: 21/Septiembre/2015 a las 16:47
Hola,

Eso huele a referencias...echale un vistazo a ver si te falta alguna
Espero te sirva !!!!!!
Iñaki
Arriba
gdelucchi Ver desplegable
Administrador
Administrador
Avatar

Unido: 14/Febrero/2005
Localización: Argentina
Estado: Sin conexión
Puntos: 6818
Enlace directo a este mensaje Enviado: 21/Septiembre/2015 a las 16:56
Y antes de copiarla al ordenador compacta la base de datos y luego la copias mediante otro medio, también mira que no te quede la mdb como de lectura solo.
Saludos - Tavo
Arriba
arcangelcaos Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 15/Noviembre/2012
Localización: España
Estado: Sin conexión
Puntos: 236
Enlace directo a este mensaje Enviado: 21/Septiembre/2015 a las 19:32
Gracias, las librerías la comprobé y están las mismas. La cosa es otras BD si las abre sin problemas, es esa en concreto. Y lo peor, es que si edito un formulario, ya funciona bien, y cuando la cierro y la vuelvo a abrir ya no funciona.
Pase el depurador de código para arreglar códigos sueltos que se quedaron por hay sin uso, de botones quitados y que no se borro el ocdigo, y ahora parece que funciona
Arriba
alexmubo Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 15/Diciembre/2010
Localización: Colombia
Estado: Sin conexión
Puntos: 464
Enlace directo a este mensaje Enviado: 22/Septiembre/2015 a las 23:50
Cuando me ha sucedido eso, con algunos formularios, y no se por que, lo que hago es crear de nuevo una base de datos de access en blanco e importo todos los objetos del "malo" y se me ha solucionado el problema.
Dejar que todos den sus ideas es mas inteligente que pensar que uno se las sabe todas.
Arriba
arcangelcaos Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 15/Noviembre/2012
Localización: España
Estado: Sin conexión
Puntos: 236
Enlace directo a este mensaje Enviado: 24/Octubre/2015 a las 22:29
Gracias, no se exactamente que puede ser, me pasa a veces, que al copiarse la version nueva en algunos ordenadores deja de funcionar el código VBA, da error.

Tengo que ir borrar la BD copiada, borrar el archivo temporal que crea y tal, y volver a copiarla y se arregla, incluso me he dado cuenta que si abro otra bd, y luego abro esta se abre bien. No tengo ni idea por que.

Cerrar el tema, no tengo explicaciones de porque sucede, simplemente copiar otra vez y listo.
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable