** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - formula fecha con o sin celda vacia
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

formula fecha con o sin celda vacia

 Responder Responder
Autor
Mensaje
anna Ver desplegable
Moderadora
Moderadora
Avatar

Unido: 11/Octubre/2004
Localización: Mexico
Estado: Sin conexión
Puntos: 4712
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita anna Cita  ResponderRespuesta Enlace directo a este mensaje Tema: formula fecha con o sin celda vacia
    Enviado: 21/Junio/2022 a las 04:17
Hola a todos

Aqui dando un poco de lata, es que ya soy muy mayor y me cuesta mas trabajo quitarme el oxido jajajaja Unhappy

Es sencillo, tengo un excel con varios campos de fecha todo va bien mientras ambas celdas tengan datos, pero cuando la segunda celda no tiene datos obvio me arroja error.....

Como condicionar que si la celda 2 no tiene datos tome hoy() como el dato activo y si tiene datois pues nada que haga el calculo ?


=DATEDIF(G4,I4,"D")
=SIFECHA(G4,I4,"D")

Gracias

Cuantas veces cómplices, yo siempre tu niña, tu siempre mi heroe!!!!
Arriba
lbauluz Ver desplegable
Administrador
Administrador
Avatar

Unido: 29/Marzo/2005
Localización: La Gloria
Estado: Sin conexión
Puntos: 3740
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita lbauluz Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 21/Junio/2022 a las 09:51
Prueba =IFERROR(DATEDIF(G4,I4,"D"); 0)

Un saludo.

Luis
El Búho es un pajarraco
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5874
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita AnSanVal Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 21/Junio/2022 a las 11:01
¡Saludos Anna!


anna ► «... si la celda 2 no tiene datos tome hoy()...»

ASV ► (Mi Excel es en español) la fórmula sería (casi la de Luís Wink):
=SI.ERROR(SIFECHA(G2;I2;"D");SIFECHA(G2;HOY();"D"))



Saludos desde Tenerife.

Mi sitio_web con ejemplos Excel.
Arriba
xavi Ver desplegable
Administrador
Administrador
Avatar
Terrassa-BCN

Unido: 10/Mayo/2005
Localización: Catalunya ||||
Estado: Sin conexión
Puntos: 14223
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita xavi Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 21/Junio/2022 a las 17:20
Hola,

Veo que utilizais la SIFECHA, función que no está documentada por el Intellisense.

Yo, viendo el enunciado "si la celda 2 no tiene datos", ergo está vacía, sugeriría otra opción. 

(siendo A1 la celda 1 y B1 la celda 2)

=SI(ESBLANCO(B1);HOY();B1)-A1
Xavi, un minyó de Terrassa

Mi web
Arriba
anna Ver desplegable
Moderadora
Moderadora
Avatar

Unido: 11/Octubre/2004
Localización: Mexico
Estado: Sin conexión
Puntos: 4712
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita anna Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 22/Junio/2022 a las 03:16
Chicos son lo maximo!!!!!!

Gracias a los 3, la unica formula que funciono fue la del Guapo

=IF(ISBLANK(B1),TODAY(),B1)-A1
Por alguna razon my excel no va con ; y solo va con  , (coma)

Los extrañCry
Cuantas veces cómplices, yo siempre tu niña, tu siempre mi heroe!!!!
Arriba
Mihura Ver desplegable
Administrador
Administrador
Avatar

Unido: 06/Mayo/2005
Localización: En la dehesa
Estado: Sin conexión
Puntos: 13305
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Mihura Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 22/Junio/2022 a las 08:40
Publicado originalmente por anna anna escribió:

Chicos son lo maximo!!!!!!

Los extrañCry

Y nosotros a nuestra Princesa.... Hug
Jesús Mansilla Castells.
Saludos desde Móstoles.

Access Aplicaciones
Tecsys.es
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable