** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - Hacer referencia a un cuadro combinado de formular
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Hacer referencia a un cuadro combinado de formular

 Responder Responder Página  <12
Autor
Mensaje
mounir Ver desplegable
Colaborador
Colaborador


Unido: 09/Febrero/2009
Localización: Asturias-España
Estado: Sin conexión
Puntos: 4922
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita mounir Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 06/Diciembre/2018 a las 23:24
Hola!

Pero, ¿cuantas columnas tiene? y ¿Cuál es el numero de la columna dependiente?

Editado por mounir - 06/Diciembre/2018 a las 23:24
Un Saludo.
Arriba
Axl666 Ver desplegable
Colaborador
Colaborador


Unido: 18/Octubre/2005
Localización: Mexico
Estado: Sin conexión
Puntos: 853
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Axl666 Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 07/Diciembre/2018 a las 19:26
 
Hola

Columna dependiente= 1
Numero de columnas = 2

Saludos,

Arriba
pitxiku Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 27/Septiembre/2017
Localización: En mi casa
Estado: Sin conexión
Puntos: 759
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita pitxiku Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 10/Diciembre/2018 a las 11:28
Cita
El cuadro combinado esta formado de la siguiente manera en lista de valores:
1;"Entidad";2;"Ledger"

Tu separador de lista, ¿no es la coma?

También puedes hacer una prueba: en vez de hacer referencia al control, que la consulta te pida el parámetro:

Elegir([Dime la columna], [00 BD PPTO 2006]![PRESUPUESTO], [00 BD PPTO 2006]![Tipo_Gasto])

Y ejecuta la consulta directamente: si así te funciona, tienes el problema en la referencia al control.
Arriba
Axl666 Ver desplegable
Colaborador
Colaborador


Unido: 18/Octubre/2005
Localización: Mexico
Estado: Sin conexión
Puntos: 853
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Axl666 Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: Ayer a las 00:10
 
Es correcto el punto y coma

Ejecute de la siguiente manera la instrucción y se ejecuto correctamente ya que le di el valor fijo,

Expr1: Elegir(1,[Pyin],[Anio])

No le encuentro que pueda tener mal en esta;

Expr1: Elegir(Val([Forms]![frm_Seg]![cbo_Tipo]),[Pyin],[Anio])

Saludos,


Arriba
 Responder Responder Página  <12
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable