** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - Indice de columna
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoIndice de columna

 Responder Responder
Autor
Mensaje
Medardo Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 03/Marzo/2005
Localización: Cuba
Estado: Sin conexión
Puntos: 1987
Enlace directo a este mensaje Tema: Indice de columna
    Enviado: 24/Agosto/2012 a las 21:40
Hola

Tengo lo siguiente:

   A                                    B        
1 Pinar del Río                   Artemisa
2 Sandino                          Mariel
3 Mantua                           Caimito
4 Viñales                            Bauta
5 La Palma                        Candelaria
6 San Luis                         San Cristóbal

Necesito saber en qué columna está "Mantua" dentro del rango A1:B6, por lo que debe devolverme "1" (su índice).

Gracias

Saludos
Desde La Habana, Cuba
Medardo
Arriba
oirausu Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 25/Diciembre/2005
Localización: España
Estado: Sin conexión
Puntos: 4217
Enlace directo a este mensaje Enviado: 24/Agosto/2012 a las 22:59
¿Por qué corresponde 1 a Mantua?
Arriba
MexMan70 Ver desplegable
Colaborador
Colaborador


Unido: 17/Julio/2007
Localización: DarkSide
Estado: Sin conexión
Puntos: 9235
Enlace directo a este mensaje Enviado: 24/Agosto/2012 a las 23:04

Y para que necesitas sabel la columna ??

Si deseas saber la provincia:
=BUSCARV(B2,$H$2:$I$6,2,FALSO)
 
Si deseas saber el indice del renglon de la matriz:
=COINCIDIR(B2,$H$1:$H$6,0)
 
 
OneDrive: http://sdrv.ms/Vk6eJd
Arriba
emiliove Ver desplegable
Moderador
Moderador


Unido: 16/Junio/2009
Localización: Mexico
Estado: Sin conexión
Puntos: 5212
Enlace directo a este mensaje Enviado: 25/Agosto/2012 a las 15:37
O tambien puedes usar las funciones Indice y Coincidir juntas mira ejemplo:
 
 
Saludos.
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5636
Enlace directo a este mensaje Enviado: 25/Agosto/2012 a las 22:03

Si en una base de datos tengo nombres de ciudades,  nunca se me ocurriría tener varios campos (en el caso de Excel columnas) con nombres de ciudades. Por tanto el nombre de una ciudad solamente podría estar en dicha columna. Ouch

 
Como hay gustos para todo y para no llenar una fórmula de condicionales... se me ocurre que lo hagas con VBA.
 

Algo similar a...

 
Function col(dato$)

  Dim n&

  On Error Resume Next

  For n = 1 To 10

    col = Worksheets(1).Range(Cells(1, n), Cells(20, n)).Find([J1]).Column

    If Not (col = Empty) Then Exit Function

  Next n

End Function

 
... y en la celda donde quieras el resultado:  =col("Mantua")
 
 
Aprendemos intentando resolver dudas ajenas (ayuda cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5636
Enlace directo a este mensaje Enviado: 25/Agosto/2012 a las 22:16
 

Tambien podrías (sin VBA) en una fila de control, poner la fórmula: =SI(ESERROR(COINCIDIR($J$1;A2:A200;0));0;COLUMNA(A1)) * , copias/pegas hacia la derecha y posteriormente te basta con sumar la fila de control.

 
* Nota: Aqui supongo que en J1 está el nombre a buscar.
Aprendemos intentando resolver dudas ajenas (ayuda cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
toldeman Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 15/Noviembre/2007
Estado: Sin conexión
Puntos: 402
Enlace directo a este mensaje Enviado: 27/Agosto/2012 a las 16:56
Hola.

Otra mas:

=COLUMNA(INDICE(A1:B6;SUMAPRODUCTO((A1:B6=C1)*(FILA(1:6)));SUMAPRODUCTO((A1:B6=C1)*(COLUMNA(A1:B1)))))


Suponiendo que en c1 se encuentre el valor a buscar.

Un saludo.
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable