** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - month() condicional
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradomonth() condicional

 Responder Responder
Autor
Mensaje
cpampasPT Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 20/Marzo/2010
Localización: Portugal
Estado: Sin conexión
Puntos: 500
Enlace directo a este mensaje Tema: month() condicional
    Enviado: 14/Julio/2019 a las 22:58
Hola amigos,

Sabeis como puedo inserir en una celda el importe 600 en caso de que el numero de mes de una fecha este entre 5 y el 9 . hasta ahora intente esto pero no resulta

=SE(and(MONTH(A3)>=5;MONTH(A3)<=9);600; 0)
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5488
Enlace directo a este mensaje Enviado: 15/Julio/2019 a las 13:19

¿En que idioma tienes Excel?


Si es español escribe:  =SI(Y(MES(A3)>=5;MES(A3)<=9);600; 0)

Si es inglés escribe:  =IF(AND(MONTH(A3)>=5;MONTH(A3)<=9);600; 0)

Si es otro idioma (¿portugués?)... corrige según convenga, de acuerdo con la sintaxis.


>> EDITADO: Según el traductor, Podría ser algo como: =SE(E(MÊS(A3)>= 5 ;MÊS(A3)<=9);600;0)


NOTA: Ten en cuenta (también) que separador de argumentos debes emplear (según tu configuración regional), en mi caso es el  ;  (punto y coma).




Editado por AnSanVal - 15/Julio/2019 a las 13:39
Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
prga Ver desplegable
Moderador
Moderador


Unido: 16/Noviembre/2004
Localización: España
Estado: Sin conexión
Puntos: 3206
Enlace directo a este mensaje Enviado: 15/Julio/2019 a las 13:39
Hola.
Complementando lo aportado por Antonio, 
Nos vamos al VBA y ejecutamos el siguiente código:

ActiveCell.Formula = "=IF(AND(MONTH(a3)>=5, MONTH(a3)<=9),600,0)"

y excel se encarga de "colocarlo" en la celda activa en el idioma en el que esté instalado el excel.
Espero que ayude a resolver la duda.
Ya comentas.
Un saludo a todos
Arriba
cpampasPT Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 20/Marzo/2010
Localización: Portugal
Estado: Sin conexión
Puntos: 500
Enlace directo a este mensaje Enviado: 17/Julio/2019 a las 23:16
funciona genial

=SE(E(MÊS(A3)>= 5 ;MÊS(A3)<=9);600;0)

nuchas gracias y podeis cerrar el hilo
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable