** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - máximos y mínimos por columna completa
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradomáximos y mínimos por columna completa

 Responder Responder
Autor
Mensaje
moctezuma48 Ver desplegable
Nuevo
Nuevo


Unido: 01/Octubre/2010
Estado: Sin conexión
Puntos: 38
Enlace directo a este mensaje Tema: máximos y mínimos por columna completa
    Enviado: 05/Enero/2011 a las 18:12
¡Hola de nuevo!
 
Mi pregunta es la siguiente:
 
tengo el siguiente rango de datos
 
A         B        C        D        E        F         G              H      I
2 1 4 2 1 2 2 7 0
2 32 2 2 4 24 2 46 2
12 13 5 2 3 6 3 42 0
3 0 7 2 36 14 4 39 0
16 0 4 3 0 0 30 35 0
 
Las columnas A-G son datos, la columna H me marca el máximo que deberían tomar los datos de cada fila y la I columna los mínimos.
 
Lo que quiero saber es si hay alguna fórmula de tipo matricial para que me diga si TODAS las filas de una misma columna están comprendidas entre los valores máximos y mínimos de las columnas H-I
 
Muchas gracias por la ayuda
 
Arriba
sdgm Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 21/Abril/2005
Localización: Guatemala
Estado: Sin conexión
Puntos: 906
Enlace directo a este mensaje Enviado: 05/Enero/2011 a las 20:39
Déjame ver si te entiendo:
 
Si quisieras verificar si en la columna B, alguna celda está fuera de los límites establecidos por las columnas "H" e "I", podrías utilizar la siguiente fórmula:
 
=SUMAPRODUCTO((B:B<I:I)*1)+SUMAPRODUCTO((B:B>H:H)*1)
 
Esta te daría el total de datos que estuvieron bajo el límite inferior (columna I) y por encima del límite superior (columna H).  El unico inconveniente será la lentitud (relativa) de la fórmula al tener que evaluar la columna completa.  Si pudieras limitar tu rango, por ejemplo a 100 filas, podrías probar con:
 
=SUMAPRODUCTO((B1:B100<I1:I100)*1)+SUMAPRODUCTO((B1:B100>H1:H100)*1)
 
Ahora, si quisieras encontrar cuál fue el dato que se salió del rango, un formato condicional podría ser una respuesta interesante.  Para esto, mejor si abres otro hilo.
 
Saludos!
 
 


Editado por sdgm - 05/Enero/2011 a las 20:40
Cordialmente, David
Arriba
moctezuma48 Ver desplegable
Nuevo
Nuevo


Unido: 01/Octubre/2010
Estado: Sin conexión
Puntos: 38
Enlace directo a este mensaje Enviado: 05/Enero/2011 a las 21:29
ClapClapClap Gracias por la respuesta.
 
Era exactamente lo que estaba buscando, simplemente le he añadido un condicional en la última fila para que me diga "sí" o "no"
 
=SI(SUMAPRODUCTO((A125:A216<AXD125:AXD216)*1)+SUMAPRODUCTO((A125:A216>AXC125:AXC216)*1)>0;"NO";"SÍ")
 
Hilo cerrado por mi parte
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable