** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - MySQL ODBC y error al vincular "#Eliminado"
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoMySQL ODBC y error al vincular "#Eliminado"

 Responder Responder
Autor
Mensaje
McPegasus Ver desplegable
Habitual
Habitual


Unido: 02/Abril/2007
Localización: España
Estado: Sin conexión
Puntos: 54
Enlace directo a este mensaje Tema: MySQL ODBC y error al vincular "#Eliminado"
    Enviado: 05/Septiembre/2019 a las 03:08
Hola Accessitas, os cuento.

El escenario es el siguiente, Access 2016 y tengo una vinculación por ODBC a un MySQL.

Cuando abro la tabla o consulta varios de los registros aparecen como contenido de todos los campos #Eliminado tal y como se observa en la imagen.

Imagen 1

Si le doy al botón de Actualizar todo o pulso F5 entonces ya aparecen datos.

Imagen 2

(En el enlace se ven dos imágenes que muestran la tabla: https://1drv.ms/u/s!Alq6BfemybVajbg9YuruROBqSQEQkQ?e=FGVxzN)

El problema grabe viene cuando abro por recordset la tabla y cuando leo el primer registro el valor del campo mesage aparece vacío , se me ha jodio el tema, incluso le indico un requerí al rs.

        strSql = "SELECT subject, message, result " _
                    & "FROM wp_email_log " _
                    & "WHERE subject Like '*Inscripción en los Campeonatos Sociales*' AND result = 1"
                   
        Set rst = CodeDb.OpenRecordset(strSql, dbOpenDynaset)
        rst.Requery
       
        strOrigen = rst!message
 

 Se os ocurre alguna solución antes de cortarme un rato las venas.


 

 

 

 



Editado por McPegasus - 05/Septiembre/2019 a las 14:28
Rafael [McPegasus]
Valencia
www.mcpegasus.net
..:: Tu Access, Mi Pasión ::..
Arriba
Erick Gamer Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 08/Mayo/2016
Localización: Mexico
Estado: Sin conexión
Puntos: 204
Enlace directo a este mensaje Enviado: 05/Septiembre/2019 a las 05:17
Hola, yo no puedo apreciar las imagenes solo iconos.

Tengo Google Chrome.
Aprendiz de todos, maestro de nadie.
Arriba
jilo Ver desplegable
Colaborador
Colaborador


Unido: 19/Diciembre/2004
Localización: TAFALLA
Estado: Sin conexión
Puntos: 891
Enlace directo a este mensaje Enviado: 05/Septiembre/2019 a las 09:30
Hola,

Igual no tiene nada que ver pero has intentado así :

Set rst = CodeDb.OpenRecordset(strSql)     ', dbOpenDynaset)

En mi casos, no me ha funcionado nunca el segundo parametro de OpenRecordset cuando el primero es una sentencia SQL, sí cuando pasas el nombre de una tabla.

Prueba, de perdidos al rio !!!Wacko
Espero te sirva !!!!!!
Iñaki
Arriba
mounir Ver desplegable
Colaborador
Colaborador


Unido: 09/Febrero/2009
Localización: Asturias-España
Estado: Sin conexión
Puntos: 5226
Enlace directo a este mensaje Enviado: 05/Septiembre/2019 a las 09:46
Un Saludo.
Arriba
McPegasus Ver desplegable
Habitual
Habitual


Unido: 02/Abril/2007
Localización: España
Estado: Sin conexión
Puntos: 54
Enlace directo a este mensaje Enviado: 05/Septiembre/2019 a las 14:25
En este caso sigue haciendo lo mismo, es decir, no me arroja ningún valor.

Gracias por tu interés Jilo.




Editado por McPegasus - 05/Septiembre/2019 a las 14:26
Rafael [McPegasus]
Valencia
www.mcpegasus.net
..:: Tu Access, Mi Pasión ::..
Arriba
McPegasus Ver desplegable
Habitual
Habitual


Unido: 02/Abril/2007
Localización: España
Estado: Sin conexión
Puntos: 54
Enlace directo a este mensaje Enviado: 05/Septiembre/2019 a las 14:32
Publicado originalmente por McPegasus McPegasus escribió:

Hola Accessitas, os cuento.
...

El problema grabe viene cuando abro por recordset la tabla y cuando leo el primer registro el valor del campo mesage aparece vacío , se me ha jodio el tema, incluso le indico un requerí al rs.

...

 


Bueno, ahora funciona ConfusedConfused, sin hacer más que apagar anoche el ordenador y volver a arrancar hace un rato.

Gracias foreros.
Rafael [McPegasus]
Valencia
www.mcpegasus.net
..:: Tu Access, Mi Pasión ::..
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable