** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - No aparecen las  propiedades
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoNo aparecen las propiedades

 Responder Responder
Autor
Mensaje
trple XXX Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 24/Enero/2023
Localización: colomba
Estado: Sin conexión
Puntos: 21
Enlace directo a este mensaje Tema: No aparecen las propiedades
    Enviado: 12/Febrero/2024 a las 20:38
Muy  buen  día  para  todos!!!!!


El problema  es   el   siguiente: en  el momento  de   estar  trabajando   despues  de  unos  años, ocurre  que  no  ejecuta  el codigo de los  botones.
Hago una  revision en  vista  diseño  del  formulario  y no aparece  para  el  caso  en concreto nada   en la  propiedad   del  botón (Al hacer  Click);   esta  bloqueada   así  mismo para  el  formulario

luego  de  esta  revision paso a Herramientas  de la base  de datos , me  dirijo a la sección  de   Visual  Basic y   reviso  la  asignación  de codigo  del  botón que  presenta error (  NO EJECUTA  NADA) y veo  que  el codigo  esta  correcto. (nada  de  ha cambiado  desde  hace  mucho  tiempo).

Hago  nuevamente  la  compilación del  codigo y no  presenta ningún error aparente.

Ya  he  cambiado la unidad  donde  se ejecuta  y  todo  sigue  igual.

No  he  recibido  actualizaciones  en la ultima  semana,  tampoco  el archivo aparece  como  solo lectura.



GRACIAS.


 
Arriba
xavi Ver desplegable
Administrador
Administrador
Avatar
Terrassa-BCN

Unido: 10/Mayo/2005
Localización: Catalunya ||||
Estado: Sin conexión
Puntos: 14746
Enlace directo a este mensaje Enviado: 12/Febrero/2024 a las 23:04
Hola,

En su momento me encontré con algo parecido y era porque se habían deshabilitado las barras de comando.

Este código me lo solucionço:

Public Function EnableCommandBars()
    Dim cmdBar  As Object
    For Each cmdBar In Application.CommandBars
        cmdBar.Enabled = True
    Next
End Function

La pones un un módulo independiente y la ejecutas. Por probar no pierdes nada. 

Un saludo
Xavi, un minyó de Terrassa

Mi web
Arriba
trple XXX Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 24/Enero/2023
Localización: colomba
Estado: Sin conexión
Puntos: 21
Enlace directo a este mensaje Enviado: 13/Febrero/2024 a las 00:27
muchas  gracias   voy  a probar   y les   comento los   resultados


Arriba
emiliove Ver desplegable
Administrador
Administrador


Unido: 16/Junio/2009
Localización: Mexico
Estado: Sin conexión
Puntos: 5694
Enlace directo a este mensaje Enviado: 13/Febrero/2024 a las 01:21
A mi me paso en access 2007, y lo solucione en el registro de windows, esta en el foro offline

saludos.
Arriba
trple XXX Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 24/Enero/2023
Localización: colomba
Estado: Sin conexión
Puntos: 21
Enlace directo a este mensaje Enviado: 13/Febrero/2024 a las 02:09

gracias  por  todo; antes  de hacer  la prueba  veo  que  en el codigo aparece en la ventana  de cada  control  "solo lectura";   ademas cuando intento  crear  un modulo aparece  al siguiente mensaje
 " error e/s de  dispositivo".

revisando  el  estado en propiedades   aparece  que  no  esta  de  solo lectura .

me parece  muy  extraño  el error  o  el  estado  del codigo.

mientras  aparece  alguna  solución coy  a copiar  todos  los  objetos a una base  nueva   y probar  que  es lo que  esta pasando.

gracias  por  su  atención y  si  es  posible  espero  alguna otra  solucion.
Arriba
trple XXX Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 24/Enero/2023
Localización: colomba
Estado: Sin conexión
Puntos: 21
Enlace directo a este mensaje Enviado: 13/Febrero/2024 a las 02:16
Precisamente  estoy  en access  2007;   me  podría  dar  la  posible  solución    con el  registro.   gracias
Arriba
trple XXX Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 24/Enero/2023
Localización: colomba
Estado: Sin conexión
Puntos: 21
Enlace directo a este mensaje Enviado: 13/Febrero/2024 a las 02:41
Por el momento  estoy reparando office

Arriba
trple XXX Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 24/Enero/2023
Localización: colomba
Estado: Sin conexión
Puntos: 21
Enlace directo a este mensaje Enviado: 18/Febrero/2024 a las 00:42
Después  de intentar muchas  soluciones,  termine pasando los  archivos (tablas y consultas ), una  base  anterior  pero  funcional  y  todo continuo normalmente.


gracias   a todos y  feliz  dia





Se puede  cerrar  el hilo
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable