** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - no inserta nombres en factura
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradono inserta nombres en factura

 Responder Responder
Autor
Mensaje
ximo Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 03/Marzo/2006
Localización: España
Estado: Sin conexión
Puntos: 2009
Enlace directo a este mensaje Tema: no inserta nombres en factura
    Enviado: 08/Enero/2020 a las 18:05
Hola,

Tengo una factura que en otro ordenador me funcionaba pero al cambiar al portátil no puedo hacer funcionar.

en una celda tengo una lista para escoger el código cliente (aunque solo los números, estaría bien que apareciera el nombre) de esta manera.

Datos==>validación de datos==>Lista ==> origen (=Clientes!$A$2:$A$3)

Luego en cada una de las celdas donde se tiene que mostrar los datos del cliente lo hago así.

=SI.ERROR(BUSCARV(B6;Clientes!$A$2:$E$3;2;FALSO);"-")
pero cuando elijo un cliente solo me muestra =SI:ERROR(...

Que puede estar pasando.


Saludos, ximo 
La incansable busqueda de información abre nuestras mentes

Saludos desde Burriana
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5632
Enlace directo a este mensaje Enviado: 08/Enero/2020 a las 22:36

Debería funcionar sin problemas.


En Opciones de Excel > Avanzadas > Mostrar opciones para esta hoja > ... 


- Confirma que esté desmarcada la opción:

Mostrar fórmulas en celdas en lugar de los resultados calculados.



Nota: Me sorprende solo dos nombres de clientes   «... (=Clientes!$A$2:$A$3) ...»






Editado por AnSanVal - 08/Enero/2020 a las 22:37
Aprendemos intentando resolver dudas ajenas (ayuda cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
ximo Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 03/Marzo/2006
Localización: España
Estado: Sin conexión
Puntos: 2009
Enlace directo a este mensaje Enviado: 09/Enero/2020 a las 13:58
Hola,

Si está desmarcada, no te sorprendas, tengo una carnicería y vendo a particulares pero tengo dos restaurantes que siempre les ha valido el tiket y al cambiar de dueño quieren factura de ahí los dos clientes.

=SI.ERROR(BUSCARV(B6;Clientes!$A$2:$E$3;2;FALSO);"-")
Manuel Ros Canós
=SI.ERROR(BUSCARV(B6;Clientes!$A$2:$E$3;3;FALSO);"-")  
=SI.ERROR(BUSCARV(B6;Clientes!$A$2:$E$3;4;FALSO);"-")  
=SI.ERROR(BUSCARV(B6;Clientes!$A$2:$E$3;5;FALSO);"-")  

Esto es lo que me aparece en las celdas donde van los datos del cliente.


Saludos, ximo
 
La incansable busqueda de información abre nuestras mentes

Saludos desde Burriana
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5632
Enlace directo a este mensaje Enviado: 11/Enero/2020 a las 11:12
Debe haber algo más, que no has visto y (como no has contado) yo no puedo ver.



Aprendemos intentando resolver dudas ajenas (ayuda cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
ximo Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 03/Marzo/2006
Localización: España
Estado: Sin conexión
Puntos: 2009
Enlace directo a este mensaje Enviado: 11/Enero/2020 a las 18:55
Hola,

Esta es la imagen de la factura es una copia en la cual el desglose del iva si funciona, no así la introducción de los datos del cliente.

En otra copia me pasa lo contrario funcionan los datos del cliente pero no el desglose del iva, creo que hay brujas Angry.

Hay algún modo de poner los datos del cliente que no sea con BUSCARV?

Si no fuera un cuadro de lista ya estaría resuelto pero no puedo entrar en él para poner código.


Saludos, ximo





Editado por ximo - 11/Enero/2020 a las 19:07
La incansable busqueda de información abre nuestras mentes

Saludos desde Burriana
Arriba
ximo Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 03/Marzo/2006
Localización: España
Estado: Sin conexión
Puntos: 2009
Enlace directo a este mensaje Enviado: 11/Enero/2020 a las 19:58
Hola,

Por fin lo he conseguido, he borrado todo y en vez de copiar y pegar para solo cambiar la columna lo he introducido todo siguiendo los pasos que te da el BUSCARV() seleccionando en cada uno de ellos la/s celdas requeridas y funciona como debe Clap.

Prometo seguir pegandome con el excel, aunque de momento no somos muy amigos creo que al final nos querremos muuuuuuuucho.


Podemos cerrar.

Saludos, ximo


La incansable busqueda de información abre nuestras mentes

Saludos desde Burriana
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable