** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - Ocultar fila
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoOcultar fila

 Responder Responder
Autor
Mensaje
renet Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 23/Abril/2009
Localización: Venezuela
Estado: Sin conexión
Puntos: 390
Enlace directo a este mensaje Tema: Ocultar fila
    Enviado: 17/Septiembre/2009 a las 19:08
Hola a todos.
 
Como puedo ocultar una fila a traves de una formula, es decir yo tengo la siguiente formula:
 
=SI(B15=7;"Junta Directiva";" AQUI QUIERO OCULTAR LA FILA??")
 
Si la celda B15 tiene el numero 7, yo debo ocultar la fila 20 para ocultar el contenido, como pudiera hacer esto?
 
Gracias
Gracias
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5515
Enlace directo a este mensaje Enviado: 17/Septiembre/2009 a las 19:43

Desde una fórmula no se puede. Pero suponiendo que el 7 en B15 lo entras a mano y no por fórmula, prueba con este código (en el módulo de la hoja):

 

Private Sub Worksheet_Change(ByVal Target As Range)

  If Target.Address = "$B$15" Then

    If Target.Value = 7 Then

      Range("G20").EntireRow.Hidden = True

    Else

      Range("G20").EntireRow.Hidden = False

    End If

  End If

End Sub

Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
renet Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 23/Abril/2009
Localización: Venezuela
Estado: Sin conexión
Puntos: 390
Enlace directo a este mensaje Enviado: 17/Septiembre/2009 a las 20:42
Gracias AnSanVal,  aunque justamente el 7 en la celda B15 viene a traves de un enlace de un valor de otra celda en la misma hoja, no se agrega a mano, si es asi entonces no funciona tu codigo? de todas lo probare y te avisare....gracias
Gracias
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5515
Enlace directo a este mensaje Enviado: 17/Septiembre/2009 a las 21:46
Publicado originalmente por renet renet escribió:

... viene a traves de un enlace de un valor de otra celda en la misma hoja...
 
¿Puedes explicar esto con más detalle?
Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable