** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - Ocultar menus
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoOcultar menus

 Responder Responder
Autor
Mensaje
i_s_m_a Ver desplegable
Nuevo
Nuevo


Unido: 01/Agosto/2011
Estado: Sin conexión
Puntos: 23
Enlace directo a este mensaje Tema: Ocultar menus
    Enviado: 29/Septiembre/2015 a las 11:33
Buenas,

Tengo una base de datos en formato 2000, que estoy abriendo con Access 2010.

Estoy intentando ocultar el menú de herramientas, y para ello tengo la siguiente línea en el evento Open del formulario inicial:
DoCmd.ShowToolbar "Ribbon", acToolbarNo

El tema es que sólo funciona cuando abro la base de datos en modo diseño. 

También he probado con Application.CommandBars("Menu Bar").Enabled = False, y tampoco funciona.

Alguna sugerencia?

Gracias.
Arriba
mounir Ver desplegable
Colaborador
Colaborador


Unido: 09/Febrero/2009
Localización: Asturias-España
Estado: Sin conexión
Puntos: 5138
Enlace directo a este mensaje Enviado: 29/Septiembre/2015 a las 13:20
Hola!

Prueba así:

CommandBars.ExecuteMso "MinimizeRibbon"
Un Saludo.
Arriba
OmniPresente Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 10/Febrero/2009
Localización: España
Estado: Sin conexión
Puntos: 1858
Enlace directo a este mensaje Enviado: 29/Septiembre/2015 a las 13:28
Pruébalo en el evento Load, en lugar de Open. Yo lo tengo ahí y me funciona.

Saludos.
Arriba
i_s_m_a Ver desplegable
Nuevo
Nuevo


Unido: 01/Agosto/2011
Estado: Sin conexión
Puntos: 23
Enlace directo a este mensaje Enviado: 29/Septiembre/2015 a las 15:03
Sí, así también me funciona en el Load y en el Open, pero siempre que la BD sea Access 2007.

El tema es que no me funciona en una BD que tiene formato Access 2000.

Al final he probado lo que comenta mounir, CommandBars.ExecuteMso "MinimizeRibbon", y me funciona tanto en Access 2000 como 2007. En realidad no oculta la barra, la minimiza, pero ya me va bien así. 

Gracias a los dos!
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable