** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - OutputTo acOutputReport
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoOutputTo acOutputReport

 Responder Responder
Autor
Mensaje
rocjfl-b Ver desplegable
Colaborador
Colaborador


Unido: 19/Abril/2006
Localización: España
Estado: Sin conexión
Puntos: 581
Enlace directo a este mensaje Tema: OutputTo acOutputReport
    Enviado: 02/Enero/2020 a las 13:01
 Feliz año a todos.
 Sabéis, por favor, porqué las imágenes gráficas que contiene el informe no se representan en el pdf?
El código que estoy utilizando es el siguiente:

DoCmd.OutputTo acOutputReport, "ContabilidadFacturaAlquiler", acFormatPDF, CurrentProject.Path & "\Informe.pdf", False

Saludos.

Arriba
prga Ver desplegable
Moderador
Moderador


Unido: 16/Noviembre/2004
Localización: España
Estado: Sin conexión
Puntos: 3285
Enlace directo a este mensaje Enviado: 02/Enero/2020 a las 13:51
Hola.
A veces hay que abrirlo previamente y luego pasarlo a pdf, o sea:

DoCmd.OutputTo acOutputReport, "ContabilidadFacturaAlquiler", acViewPreview
DoEvents
DoCmd.OutputTo acOutputReport, , acFormatPDF, CurrentProject.Path & "\Informe.pdf", False
DoCmd.Close acReport, Screen.ActiveReport.Name

Escrito de memoria, así es que....
Espero que de resultado.
Ya comentas.
Un saludo a todos
Arriba
rocjfl-b Ver desplegable
Colaborador
Colaborador


Unido: 19/Abril/2006
Localización: España
Estado: Sin conexión
Puntos: 581
Enlace directo a este mensaje Enviado: 02/Enero/2020 a las 17:27
Gracias prga.
El problema está en otro sitio.
Tanto si la imagen es insertada como vinculada en el control, al seleccionar "zoom" en la propiedad "Modo de cambiar de tamaño",  la imagen no se representa en el informe; 
si se selecciona "extender" o "recortar", ésta se representa sin problema.
Lo que no entiendo es porqué al seleccionar "zoom" la imagen no se representa.

Arriba
prga Ver desplegable
Moderador
Moderador


Unido: 16/Noviembre/2004
Localización: España
Estado: Sin conexión
Puntos: 3285
Enlace directo a este mensaje Enviado: 02/Enero/2020 a las 17:47
Había entendido que el problema estaba al pasar a PDF y no en el propio informe.
¿Qué versión de office se  utiliza?
Ya comentas.
Arriba
rocjfl-b Ver desplegable
Colaborador
Colaborador


Unido: 19/Abril/2006
Localización: España
Estado: Sin conexión
Puntos: 581
Enlace directo a este mensaje Enviado: 02/Enero/2020 a las 19:11
Eso creí yo también hasta comprobar que con el código que me facilitaste seguía sucediendo lo mismo; las imágenes no aparecían.
La versión es la 2016.

Arriba
emiliove Ver desplegable
Moderador
Moderador


Unido: 16/Junio/2009
Localización: Mexico
Estado: Sin conexión
Puntos: 5070
Enlace directo a este mensaje Enviado: 02/Enero/2020 a las 19:58
¿La imagen en que formato están?, ¿en versiones anteriores funcionaba?, ¿si cambias el formato pasa lo mismo?
Prueba esto:
En Archivo=>Opciones => Base de datos actual => Formato de Almacenamiento de Propiedades de imagen; selecciona: Convertir todos los datos en imagen en mapa de bits.

Saludos.


Editado por emiliove - 02/Enero/2020 a las 19:58
Arriba
rocjfl-b Ver desplegable
Colaborador
Colaborador


Unido: 19/Abril/2006
Localización: España
Estado: Sin conexión
Puntos: 581
Enlace directo a este mensaje Enviado: 04/Enero/2020 a las 17:08
Las imágenes son en formato mapa de bits.
Después de llevar a cabo la configuración que sugiere emiliove, todas ellas se representan correctamente.
Muchas gracias a todos.
Saludos.
Se puede cerrar el hilo. 
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable