Imprimir página | Cerrar ventana

Copiar de una tabla a otra

Impreso de: Foro de Access y VBA
Categoría: Otros de Microsoft: Windows y Office
Nombre del foro: Excel
Descripción del foro: Foro de Excel y VBA de Excel
URL: http://www.mvp-access.com/foro/forum_posts.asp?TID=56294
Fecha de impresión: 22/Noviembre/2019 a las 06:48


Tema: Copiar de una tabla a otra
Publicado por: Gladiador
Asunto: Copiar de una tabla a otra
Fecha de publicación: 15/Abril/2009 a las 17:02
Buenas.
Ya he revisado las preguntas que hay en el foro y no encuentro una que lene mis expectativas. Agradezco su ayuda
 
Tengo una tabla de cada mes para anotar los productos vendidos cada dia.
En la columna A estan los códigos de los productos y en las columnas siguientes se anota el número de articulos que se ha vendido de cada producto por día.
Ejemplo
 
Producto     Dia 01    Dia 02    Dia 03    Dia 04 ...... etc
                    Cant      Cant       Cant      Cant       ....
01
02
03
04
05
06
 .
 .
 .
 
No todos los días se venden todos los productos. La venta diaria me es enviada en una hoja que me indica por ejemplo:
 
Producto      Cantidad
 01                      10
 02                        5
 04                       03
 10                       01
 15                       04
 
Necesito importar/trasladar esta información a la tabla general, donde estan asentados todos los productos de manera consecutiva.
 
Ya he intentado con BUSCARV, pero en el caso anterior, en que no aparece venta del producto 03, al aplicar la fórmula me coloca el valor del producto 02. En las celdas correspondientes a los productos 05,06,07,08,09 coloca el valor del producot 04
 
Agradezco cualquier sugenrencia
 
GRACIAS
 
 
Gladiador
 



Respuestas:
Publicado por: Gladiador
Fecha de publicación: 15/Abril/2009 a las 18:20
Hola de nuevo.
 
Imagino que ya debe haber alguien generando una respuesta a mi consulta, lo cual siempre ha sido el la buena voluntad de todos.
 
Despues de muchos intentos, creo haber llegado a una solución y ha sido la siguiente:
 
=SI(ESERROR(BUSCARV($B4;AS$120:AU$170;2;FALSO));;BUSCARV($B4;AS$120:AU$170;2;FALSO))
 
La columna "B" contiene lós códigos de los productos. Estos códigos se extienden hasta la fila 110.
La columna "C" contiene el Precio Unitario de cada producto. La columna "D" se coloca la cantidad de productos vendidos y en la "E" el precio total de la venta por dia de cada producto. Por lo tanto, el registro de un día esta compuesto por 3 columnas; en este caso, el primer día columnas "C", "D" y "E".
En la fila 120, coloco los datos que recibo, para el día especificado, es por eso que la formula hace referencia a la fila 120 como primera fila de la matrix
 
Si alguien tiene alguna mejor sugerencia, siempre será bienvenida
 



Imprimir página | Cerrar ventana