Imprimir página | Cerrar ventana

Encontrar rango selectivo

Impreso de: Foro de Access y VBA
Categoría: Otros de Microsoft: Windows y Office
Nombre del foro: Excel
Descripción del foro: Foro de Excel y VBA de Excel
URL: http://www.mvp-access.com/foro/forum_posts.asp?TID=68008
Fecha de impresión: 22/Noviembre/2019 a las 06:49


Tema: Encontrar rango selectivo
Publicado por: makinavaja
Asunto: Encontrar rango selectivo
Fecha de publicación: 11/Marzo/2011 a las 02:14
Hola a todos!

Me gustaría preguntaros una cuestión que lo redactaré con un ejemplo practico.


A1 B1 C1
6 3 4
7 2 3
8 1 2
7 4 3
7 2 2
8 1 2

Tenemos en la columna A1 y le aplicamos esta formula
=CONTAR.SI(A1:A6;6)
=CONTAR.SI(A1:A6;7)
=CONTAR.SI(A1:A6;8)
con esto sabemos cuantos '7','8','6' hay.

Pero lo que no se hacer es que cuando encuentra un 6 me diga los numeros de B1 y C1. O en su defecto, su rango u horquilla mínima y máxima.

ejemplo
tenemos 3 sietes..
7--2--3
7--4--3
7--2--2

El resultado tendría que ser:
7--(2-4)--(2-3)
7--(min/max)--(min/max). Pero en las que sea la primera columnas 7.


Lo mismo cuando sea 8 y 6.


Un saludo y gracias



Respuestas:
Publicado por: TatoSV
Fecha de publicación: 11/Marzo/2011 a las 23:30
 

Con los datos en A1:C6 y para el objetivo 7, he hecho lo siguiente:

 

E1:  "Objetivo"

F1:  7

E2:  "Encontrados"

F2:  =CONTAR.SI($A$1:$A$6;F1)

F7:  "B"

G7:  "C"

E8:  =SI($F$2>=FILA(A1);COINCIDIR($F$1;$A$1:$A$6);"")

E9:  =SI($F$2>=FILA(A2);COINCIDIR($F$1;DESREF($A$1;E8;0;6-E8);0)+E8;"")

        ( Copia/Pega hasta  E14 )

F8:  =SI($E8="";"";INDICE(B$1:B$6;$E8))

        ( Copia/Pega hasta  F14 )

G8:  =SI($E8="";"";INDICE(C$1:C$6;$E8))

        ( Copia/Pega hasta  G14 )

 
 Editado para incluir la fórmula de E9:E14.


-------------
La solidaridad nos hace más humanos.


Publicado por: makinavaja
Fecha de publicación: 18/Marzo/2011 a las 21:40
Lo siento por no contestar antes por problemas laborales.

Muchas gracias por la solucion



Imprimir página | Cerrar ventana