Imprimir página | Cerrar ventana

Condicional hombre/mujer

Impreso de: Foro de Access y VBA
Categoría: Otros de Microsoft: Windows y Office
Nombre del foro: Excel
Descripción del foro: Foro de Excel y VBA de Excel
URL: http://www.mvp-access.com/foro/forum_posts.asp?TID=72939
Fecha de impresión: 31/Octubre/2020 a las 09:06


Tema: Condicional hombre/mujer
Publicado por: daganji
Asunto: Condicional hombre/mujer
Fecha de publicación: 05/Abril/2012 a las 10:52
Buenos días.
 
Tengo esta tabla:
 

 

B

C

U

V

W

Y

 

NOMBRE 

SEXO

PRUEBA 1

PRUEBA 2

PRUEBA 3

RESULTADO

3

PEPE

HOMBRE

APTO

APTO

APTO

APTO

4

JUAN

HOMBRE

APTO

NO APTO

APTO

NO APTO

5

ROSA

MUJER

APTO

APTO

APTO

APTO

 
en la columna Y, me da el resultado de APTO ó NO APTO, si las tres pruebas son APTAS, y en el caso que una de ellas fuese NO APTO, ya me daría NO APTO, después de aplicar la siguiente fórmula:
 
=SI(Y(U3="apto";V3="APTO";W3="APTO");"APTO";"NO APTO").
 
Mi Pregunta es la siguiente:
 
1º Como veis en la columna C, está el sexo, quisiera que dependiendo de ello, el resultado fuese apto o apta, no apto o no apta, tanto en cada una de las pruebas, como en el resultado final.
 
Muchas gracias
 
 
 
 



Respuestas:
Publicado por: Jordi-Albert
Fecha de publicación: 05/Abril/2012 a las 11:33
suponiendo que APTO/APTA de la columna U tiene la terminacion correcta, puedes usar la siguiente formula

=SI(LARGO(U3&V3&W3)=12; DERECHA(U3;4); "No " & DERECHA(U3;4))

es decir, creo una cadena con el resultado de "AptoAptoApto" y si no da 12 significa que hay algun "NO", pòr lo que el resultado es "NO" + las 4 ultimas letras del valor de U3

espero que no tengas problemas al respecto



-------------
Nota: Jordi-Albert es, todo él, un nombre. Mi nombre


Publicado por: Jordi-Albert
Fecha de publicación: 05/Abril/2012 a las 11:38
en caso de que no lo puedas saber, podrias hacer

=SI(LARGO(U3&V3&W3)=12; ""; "No ") & "Apt" & SI(MAYUSC(C3)="HOMBRE"; "o";"a")


-------------
Nota: Jordi-Albert es, todo él, un nombre. Mi nombre


Publicado por: daganji
Fecha de publicación: 05/Abril/2012 a las 12:26

Muchas gracias Jordi, sobre todo por tu pronta respuesta y sabiduría.

 
La segunda opción que me has puesto me funciona correctamente.
 
=SI(LARGO(U3&V3&W3)=12; ""; "No ") & "Apt" & SI(MAYUSC(C3)="HOMBRE"; "o";"a")
 
Puedes cerrar el hilo.



Imprimir página | Cerrar ventana