** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - Problema desde hace 2 semanas con webBrowser
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Problema desde hace 2 semanas con webBrowser

 Responder Responder
Autor
Mensaje
msgambero Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 06/Abril/2010
Localización: España
Estado: Sin conexión
Puntos: 214
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita msgambero Cita  ResponderRespuesta Enlace directo a este mensaje Tema: Problema desde hace 2 semanas con webBrowser
    Enviado: 10/Diciembre/2018 a las 15:47
CryCry Buenas tardes, estoy que no se que hacer, tengo una función en mi aplicación que utiliza el traductorde google, pero desde hace un par de semanas ya no funciona... Utilizo webBrowser, access2007 y windows 10. 
El mensaje de error que da es el siguiente:

Error en el script de esta página
...
...
URL:  https://translate.google.es/?hl=es

Tengo una miniaplicacion que puedo enviar por email, ....

CryCry
Sigo aprendiendo en este foro y espero poder ayudar. GRACIAS
Arriba
emiliove Ver desplegable
Moderador
Moderador


Unido: 16/Junio/2009
Localización: Mexico
Estado: Sin conexión
Puntos: 4991
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita emiliove Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 10/Diciembre/2018 a las 16:00
Hola msgambero

Google a cambiado su traductor, puedes mirar en el foro offline ahí Recuerdo que Happy, dio una excelente (mini manual) respuesta de como tratar las páginas de HTML.

Saludos.
Arriba
msgambero Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 06/Abril/2010
Localización: España
Estado: Sin conexión
Puntos: 214
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita msgambero Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 10/Diciembre/2018 a las 16:20
Me parece que el foro offline se actualizó en el 2016 si lo he visto bien, y mi problema es de hace 2 semanas, ....

Sigo aprendiendo en este foro y espero poder ayudar. GRACIAS
Arriba
msgambero Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 06/Abril/2010
Localización: España
Estado: Sin conexión
Puntos: 214
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita msgambero Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 10/Diciembre/2018 a las 16:38
Estoy mirando en internet, y parece que este problema ya se ha dado a otras personas, lo que no encuentro es la forma de delimitarlo o centrarlo. he creado un .rar con un ejemplo sencillo y la imagen del error que me da. os agradecería que lo vierais y me dierais vuestra opinión. Yo lo he probado en varios ordenadores y en todos tengo el mismo problema.
Muchas gracias anticipadas.

http://xml.cspisos.es/traductorgoogle.rar

Sigo aprendiendo en este foro y espero poder ayudar. GRACIAS
Arriba
emiliove Ver desplegable
Moderador
Moderador


Unido: 16/Junio/2009
Localización: Mexico
Estado: Sin conexión
Puntos: 4991
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita emiliove Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 10/Diciembre/2018 a las 21:18
Creo que me explique mal, para poder interactuar con una página web, necesitas ver su estructura y hace dos semanas Google cambio la estructura de su traductor, el Happy dio una explicación muy detallada de como entender las estructuras de las páginas web (en general), como por medio del DOM (Modelo de objetos del documento) puedes saber los elementos, los métodos y los eventos que usa y poder mediante vba access, controlarlos y ejecutarlos.
La idea es que te pongas a estudiar y si lo intentas y no lo consigues con gusto me hecho un clavado por ti, El tema se llama: interactuar con Web

Saludos.
Arriba
msgambero Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 06/Abril/2010
Localización: España
Estado: Sin conexión
Puntos: 214
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita msgambero Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 11/Diciembre/2018 a las 08:46
Estimado emiliove, te agradezco enormemente las indicaciones y ojalá tuviera tiempo para estudiar en detalle muchas cosas, pero soy autónoma gerente de oficina inmobiliaria, con 55 años, y voy a necesitar a un profesional para poder comercializar la aplicación en la que llevo trabajando en los huecos y fines de semana casi 10 años. Mi intención es hacerlo en un plazo de unos 3 meses, pero ahora mismo necesito resolver este problema que me está afectando en las 3 oficinas donde se están utilizando mi aplicación mas de 15 personas. Si me puedes agilizar para resolverlo te lo agradecería no sabes cuanto. de todas formas si me pasas directamente el enlace de happy que me referencias me ahorras tiempo también y así lo voy viendo.

Espero que puedas entender mi situación y una vez más agradezco la implicacion de los moderadores de este foro que me han ayudado con cada obstaculo que me he encontrado. Thumbs Up
Sigo aprendiendo en este foro y espero poder ayudar. GRACIAS
Arriba
msgambero Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 06/Abril/2010
Localización: España
Estado: Sin conexión
Puntos: 214
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita msgambero Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 12/Enero/2019 a las 13:20
Buenos dias, sigo sin poder resolverlo y necesitaria asesoramiento, con quien puedo contactar directamente? Si tiene honorarios la consulta me lo decis, pero ya no sé qué más hacer .... y es urgente.

Gracias
Sigo aprendiendo en este foro y espero poder ayudar. GRACIAS
Arriba
msgambero Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 06/Abril/2010
Localización: España
Estado: Sin conexión
Puntos: 214
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita msgambero Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 13/Enero/2019 a las 10:28
Buenos dias, quisiera hacer una pregunta, si no recibo respuestas es porque no hay una solución clara  Cry ?
Sigo aprendiendo en este foro y espero poder ayudar. GRACIAS
Arriba
Mihura Ver desplegable
Administrador
Administrador
Avatar

Unido: 06/Mayo/2005
Localización: En la dehesa
Estado: Sin conexión
Puntos: 11096
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Mihura Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 13/Enero/2019 a las 13:10
Esta claro que de la gente que está leyendo no hay nadie que tenga una solución clara al asunto que preguntas.

Por otro lado, la solicitud de asesoramiento 'con honorarios' que pides, 
- me creo que los que 'controlan' el tema andan muy liados para ponerse con este asunto
- los que no lo controlamos (mi caso), aparte de encontrar el hueco para hacerlo, el tiempo de buscar la información, investigar, probar y conseguir que funcione me da que implicará unos costes elevados.

A ver si alguien más te responde.


Jesús Mansilla Castells.
Saludos desde Móstoles.

Access Aplicaciones
Tecsys.es
Arriba
mounir Ver desplegable
Colaborador
Colaborador


Unido: 09/Febrero/2009
Localización: Asturias-España
Estado: Sin conexión
Puntos: 5226
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita mounir Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 13/Enero/2019 a las 15:48
Hola!

A ver si te sirve:
Abre inernet Explorer >>> en herramientas >>>>> Opciones de internet >>>
haga clic en la pestaña avanzada. En la sección "Examinar":
- Deshabilitar la depuración de Script (Internet Explorer) - Marcar.
- Deshabilitar depuración de scripts (otros) - Marcar.
- Mostrar una notificación de cada error de script - Sin marcar.


otra información:
https://support.microsoft.com/es-es/help/308260/how-to-troubleshoot-script-errors-in-internet-explorer

Espero que te sirva

Editado por mounir - 13/Enero/2019 a las 15:51
Un Saludo.
Arriba
pitxiku Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 27/Septiembre/2017
Localización: En mi casa
Estado: Sin conexión
Puntos: 1039
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita pitxiku Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 13/Enero/2019 a las 16:52
Otra cosa:

Si no he entendido mal, para usar el API de Google hay que pagar:

- https://es.wikipedia.org/wiki/Traductor_de_Google
- https://es.wikipedia.org/wiki/Traductor_de_Google#API
- https://cloud.google.com/translate/pricing?hl=es

De hecho, si usas alguno de los múltiples códigos que hay en la Web, o dan errores, o no traducen lo que se desea.

Pero el traductor online parece que sigue siendo operativo. Si ejecutas la dirección que usas en tu base de datos, funciona y Google lo traduce, aunque luego tienes que trabajar con el navegador que tengas:

Application.FollowHyperlink "http://translate.google.es/?hl=es&tab=wT#es|en|" & Me.txtEspañol

No es una solución muy buena, pero puede servir de parche hasta que encuentres otra mejor.
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable