** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - problemas con buscarv y encontrarv
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoproblemas con buscarv y encontrarv

 Responder Responder
Autor
Mensaje
ximo Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 03/Marzo/2006
Localización: España
Estado: Sin conexión
Puntos: 1908
Enlace directo a este mensaje Tema: problemas con buscarv y encontrarv
    Enviado: 18/Noviembre/2018 a las 12:03
Hola,

Buenos días, tengo un problema, no puedo hacer funcionar ninguna de las formulas mencionadas (buscarv/encontrarv), tengo un exccel que me paso mi gestor con el cual no me siento agusto por lo siguiente, el exccel tiene 9 hojas (4 de compras (trimestres), 4 de ventas, resumen ) cuando pongo un proveedor la segunda vez ya se rellena con la coincidencia pero todos los trimestres los tengo que poner, por otro lado debo poner el cif/nif y es lo más problemático ya que la mayoría de empresas lo ponen en el lateral  con la letra ínfima, resumiendo debo leer todas las facturas y me cuesta mucho introducirlas.

Buscando en San Google encontré mi salvación  la función (BUSCARV() o ENCONTRARV()) según tengamos el servipak1 o no en exccel 2010, pero no hay manera de hacerlo funcionar.

He creado dos hojas (hoja2,hoja3) en hoja2 tengo dos columnas (NOMBRE, CIF) para poder poner todas las empresas y sus nif, en hoja3 he puesto dos columnas (NOMBRE, CIF) donde nombre he convertido en un combo que muestra los datos de la hoja2 para elegir uno, y en la columna (CIF) pretendo aplicar la función BUSCARV() sin resultado siempre me pone #¿NOMBRE? y marca error.

=SI.ERROR(BUSCARV(A2;Tabla2;2;FALSO);"-")
También intentado así:

=SI.ERROR(ENCONTRARV(A2;Hoja2!$A$2:$B$5;2;FALSO);"-")

No se si estoy haciéndolo mal o que ocurre.


Saludos, ximo 
La incansable busqueda de información abre nuestras mentes

Saludos desde Burriana
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5419
Enlace directo a este mensaje Enviado: 18/Noviembre/2018 a las 12:47
Que yo sepa, ENCONTRARV no existe ni ha existido en ninguna versión de Excel.

La que sí existió en la primera versión de Excel 2010 fue CONSULTAV, pero en la actualización (tras las quejas de los usuarios) regresaron nuevamente a BUSCARV.

Si BUSCARV te devuelve el error  #¿NOMBRE? (significaría que Office no está actualizado), utiliza:

CONSULTAV(A2;Tabla2;2;FALSO)


Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
ximo Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 03/Marzo/2006
Localización: España
Estado: Sin conexión
Puntos: 1908
Enlace directo a este mensaje Enviado: 18/Noviembre/2018 a las 15:50
Gracias Antonio,

Todo funcionando perfectamente.
Podemos cerrar.

Saludos, ximo

PD: Al entrar el sistema me dice que tengo tres hilos abiertos pero no los encuentro y creo sinceramente que no es así. Revisarlo por favor.
La incansable busqueda de información abre nuestras mentes

Saludos desde Burriana
Arriba
Mihura Ver desplegable
Administrador
Administrador
Avatar

Unido: 06/Mayo/2005
Localización: En la dehesa
Estado: Sin conexión
Puntos: 10718
Enlace directo a este mensaje Enviado: 18/Noviembre/2018 a las 18:15
Pues yo veo cuatro ...  LOL

Entra en el buscador, opción búsqueda avanzada, búsqueda por nombre, temas iniciados por el usuario, pon que busque en cualquier fecha y que muestre resultados como Temas.

Esperamos tus resultados .... Big smile


Jesús Mansilla Castells.
Saludos desde Móstoles.

Access Aplicaciones
Tecsys.es
Arriba
ximo Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 03/Marzo/2006
Localización: España
Estado: Sin conexión
Puntos: 1908
Enlace directo a este mensaje Enviado: 19/Noviembre/2018 a las 15:03
Hola,

Pues a mi solo dos con este, el otro es de Exccel ya he notificado, pero la cantidad de mensajes que me salen todos pertenecen al la misma persona (ximo200) que no soy yo, alguna vez se ha comentado si era un segundo alias pero no.

De todas formas si alguno se me ha pasado haz el favor de cerrarlo.


Saludos, ximo
La incansable busqueda de información abre nuestras mentes

Saludos desde Burriana
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable