** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - Procedimiento de evento y event procedure
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Procedimiento de evento y event procedure

 Responder Responder
Autor
Mensaje
xavi Ver desplegable
Administrador
Administrador
Avatar
Terrassa-BCN

Unido: 10/Mayo/2005
Localización: Catalunya ||||
Estado: Sin conexión
Puntos: 12077
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita xavi Cita  ResponderRespuesta Enlace directo a este mensaje Tema: Procedimiento de evento y event procedure
    Enviado: 03/Octubre/2019 a las 14:03
Hola,

No se si a alguien le ha pasado pero me he encontrado recientemente con algún problema con aplicaciones de mis clientes en relación al literal "Procedimiento de evento",

Mi Office está en castellano por lo que, en la hoja de propiedades aparece [Procedimiento de evento]. En una versión en inglés aparece [Event procedure].

Hasta la fecha he desarrollado aplicaciones en office-es que kuego han corrido en office-en sin problema alguno. Ahora recibo mensajes (no siempre, más raro aun) de los ordenadores office-en que no se encuentra la macro "Procedimiento de evento". Es como si, en ocasiones, el sistema no realizara la traducción.

¿Alguna sugerencia?

De momento al botón del formulario "rebelde" le fuerzo, por VBA que su evento OnClick sea [Event procedure] pero no es una solución viable si el error se repite en distintos lugares, obviamente.

Un saludo
Xavi, un minyó de Terrassa

Mi web
Arriba
Erick Gamer Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 08/Mayo/2016
Localización: Mexico
Estado: Sin conexión
Puntos: 217
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Erick Gamer Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 03/Octubre/2019 a las 14:54
Aprendiz de todos, maestro de nadie.
Arriba
javier.mil Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 10/Agosto/2005
Localización: España
Estado: Sin conexión
Puntos: 4320
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita javier.mil Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 03/Octubre/2019 a las 17:45
Hola Xavi

Te comento por si te puede servir,........... Creo recordar que alguna ocasión dijiste que trabajas con Oficce 365 con lo cual solo tendrías que cambiar el IDIOMA de Access y volver a re-compilar (hacer un Debug) de la ACCDB y ya estaría solucionado el problema,....... Luego si lo deseas puedes volver a instalar el Idioma castellano ...... Suerte
Arriba
xavi Ver desplegable
Administrador
Administrador
Avatar
Terrassa-BCN

Unido: 10/Mayo/2005
Localización: Catalunya ||||
Estado: Sin conexión
Puntos: 12077
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita xavi Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 03/Octubre/2019 a las 20:34
Hola

@Javier
En realidad se desarrolló en una máquina con Office "normal" ya que lo desarrollé en cliente.
Se trata de un cliente dónde algunos usuarios pueden trabajar en el propio ordenador o en un entorno virtualizado. Las modificaciones se las hice al mismo usuario que ahora recibe el error. Tengo que averiguar en que entorno está recibiendo el error y si son iguales -de idioma- los Office de máquina física y de máquina virtual (creo recordar que son distintas). 

De todas formas, gracias por el "tip"

Un saludo

Xavi, un minyó de Terrassa

Mi web
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable