** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - recomendación para hacer aplicación
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

recomendación para hacer aplicación

 Responder Responder
Autor
Mensaje
Lulial Ver desplegable
Asiduo
Asiduo


Unido: 15/Junio/2005
Estado: Sin conexión
Puntos: 260
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Lulial Cita  ResponderRespuesta Enlace directo a este mensaje Tema: recomendación para hacer aplicación
    Enviado: 07/Marzo/2019 a las 12:35
hola
tengo que hacer una aplicación sencilla para el cáculo de cubicaje.
teniendo en cuenta que para contenedor pueden entrar varios tipos de piezas de diferentes tamaños

mi idea es exportar a excel por un lado los pedidos y por otro las medidas de las piezas pero cuál sería la mejor opción para hacerlo gráfico, que se pudiera ver el detalle del dibujo?

gracias!!
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5511
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita AnSanVal Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 07/Marzo/2019 a las 14:59
Tal vez puedas aprovechar el ejemplo 28 de mi sitio web. Es un ejemplo para bultos homogéneos, pero que puede valerte como punto de partida.


Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
Lulial Ver desplegable
Asiduo
Asiduo


Unido: 15/Junio/2005
Estado: Sin conexión
Puntos: 260
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Lulial Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 21/Marzo/2019 a las 12:03
hola
Estoy analizando el ejemplo, que está genial, tengo unas dudas
He visto que según lo que he entendido hay pequeñas erratas, pero quería comentarlas a ver si realmente lo he entendido bien, en la celda

D3 =SI(O(I3<alto;J3<ancho;K3<alto);0;ENTERO(I3/alto)*ENTERO(J3/ancho)*ENTERO(K3/fondo))
Debería ser
D3 =SI(O(I3<alto;J3<ancho;K3<fondo);0;ENTERO(I3/alto)*ENTERO(J3/ancho)*ENTERO(K3/fondo))

H4= SI(O(I4<ancho;J4<alto;K4<ancho);0;ENTERO(I4/fondo)*ENTERO(J4/alto)*ENTERO(K4/ancho))
Debería ser
H4= SI(O(I4<fondo;J4<alto;K4<ancho);0;ENTERO(I4/fondo)*ENTERO(J4/alto)*ENTERO(K4/ancho))

H10 =SI(O(I10<ancho;J10<alto;K10<ancho);0;ENTERO(I10/fondo)*ENTERO(J10/alto)*ENTERO(K10/ancho))
Debería ser
H10 =SI(O(I10<fondo;J10<alto;K10<ancho);0;ENTERO(I10/fondo)*ENTERO(J10/alto)*ENTERO(K10/ancho))

H13 =SI(O(I13<ancho;J13<alto;K13<ancho);0;ENTERO(I13/fondo)*ENTERO(J13/alto)*ENTERO(K13/ancho))
Debería ser
H13 =SI(O(I13<fondo;J13<alto;K13<ancho);0;ENTERO(I13/fondo)*ENTERO(J13/alto)*ENTERO(K13/ancho))

H16 =SI(O(I16<ancho;J16<alto;K16<ancho);0;ENTERO(I16/fondo)*ENTERO(J16/alto)*ENTERO(K16/ancho))
Debería ser
H16 =SI(O(I16<fondo;J16<alto;K16<ancho);0;ENTERO(I16/fondo)*ENTERO(J16/alto)*ENTERO(K16/ancho))

Y para entenderlo mejor me podrías dar una pequeña explicación, porque rellenas el rango I3:K20 en la posición A rellenas D y F, en la posición B rellenas D y A, en la posición C rellenas D y F, en la posición D rellenas y A, en la posición E rellenas F y A y para finalizar en la posición F rellenas D y A??



muchas gracias por tu ayuda!!
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5511
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita AnSanVal Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 21/Marzo/2019 a las 18:56
Gracias por comentar los errores encontrados, cuando tenga un poco de tiempo los revisaré. He mirado de pasada el primer caso (D3 -en tu mensaje-) y aparentemente tienes razón, hace unos cuantos años que lo hice (antes del 2000, aún curraba) y ya no lo recuerdo.

«... para entenderlo mejor me podrías dar una pequeña explicación...»
Creo recordar que en ese ejemplo, a la izquierda tienes el icono de descarga y a la derecha el icono de la explicación (sitio web).



Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
Lulial Ver desplegable
Asiduo
Asiduo


Unido: 15/Junio/2005
Estado: Sin conexión
Puntos: 260
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Lulial Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 22/Marzo/2019 a las 09:19
hola,

si ya lo he analizado con las indicaciones y con el excel, es muy bueno el ejemplo, pero todavía no termino de entender el calculo de espacios libres, según la posición de cada pieza (A,B,C,D,E o F) se calcula para rellenar Derecha, Frente o Arriba (sólo dos posibles en cada caso), no entiendo la elección de esas dos posibles.
para la posición A: D y F
para la posición B: D y A
para la posición C: D Y F
para la posición D: F y A
para la posición E: F y A
para la posición F: D y A

muchas gracias por tu ayuda!!
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5511
Opciones de entrada Opciones de entrada   Gracias (1) Gracias(1)   Cita AnSanVal Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 25/Marzo/2019 a las 12:08

Al fin encontré tiempo.


Errores:

D3.- En D3 de mi ejemplo no hay fórmula.

H4, H10, H13 y H16.- Son errores míos (culpa del Copy/Paste), tus fórmula son correctas. El cálculo es sobre la figura [H25], donde: 'ancho' es el fondo origen, 'fondo' es el alto origen y 'alto' es el ancho origen.


«... no termino de entender el calculo de espacios libres,...»

1.- En I3:K20 calculo el espacio libre (Ancho2×Fondo2×Alto2).

2.- En C3:H20 calculo el contenido que cabe en ese espacio.

3.- En las celdas no calculadas de C3:H20, no pongo fórmulas porque no cabe ningún contenido.


Ejemplos para el punto 3:

[fila 3]  no calculo las que ancho (Fig. Col) sea >= que ancho A.

[fila 4]  no calculo las que fondo (Fig. Col.) sea >= que fondo A.

[fila 5]  no calculo las que alto (Fig. Col) sea >= que alto A (cualquiera).

[fila 6]  no calculo las que ancho (Fig. Col) sea >= que ancho B.

[fila 7]  no calculo las que fondo (Fig. Col) sea >= que fondo B (cualquiera).

[fila 8]  no calculo las que alto (Fig. Col) sea >= que alto  B.


... etc.



Editado: En el ejemplo, no están controlados todos los supuestos respecto a los espacios no ocupados en la primera pasada, ya que (p. ej.) al ocupar el espacio de la derecha, se podría estar ocupando parte del espacio frontal y parte del espacio superior, y habría que controlar por separado (D-F-A, D-A-F, F-A-D, F-D-A, etc.).


Editado2: He subido un nuevo descargable, reparado y con nombres definidos en las fórmulas.





Editado por AnSanVal - 25/Marzo/2019 a las 13:30
Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
Lulial Ver desplegable
Asiduo
Asiduo


Unido: 15/Junio/2005
Estado: Sin conexión
Puntos: 260
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Lulial Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 02/Abril/2019 a las 12:40
hola, y siempre debe ser ancho > fondo > alto

no funciona si no son así los valores

es que también lo iba a usar para calcular el cubicaje en palets

gracias!!
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5511
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita AnSanVal Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 02/Abril/2019 a las 18:02
Sí, está pensado con esa idea, primero el mayor de los valores, después el valor intermedio y finalmente el menor. Pero teniendo la idea, adaptarlo a tu caso particular, debería 'costarte' menos.


Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
Lulial Ver desplegable
Asiduo
Asiduo


Unido: 15/Junio/2005
Estado: Sin conexión
Puntos: 260
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Lulial Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 10/Abril/2019 a las 14:29
hola, hecho el ejemplo, cambiando los valores en el administrador de nombres, pero no me funciona.
¿cómo puedo hacerte llegar mi cambio a ver si lo podemos analizar que me da hasta 40 cajas y es imposible?

gracias!!

Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5511
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita AnSanVal Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 11/Abril/2019 a las 13:43
Mi ejemplo es solo 'eso', un ejemplo sin pretensión de que valga para otros supuestos. Y no me ocupo en hacer aplicaciones completas para terceros, lamento no ayudarte de un modo más personal. 



Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable