** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - Redondear sumando bien
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoRedondear sumando bien

 Responder Responder
Autor
Mensaje
arodrigu Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 04/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 565
Enlace directo a este mensaje Tema: Redondear sumando bien
    Enviado: 04/Octubre/2010 a las 13:12
Buenos días:
He mirado en la búsqueda y no encuentro nada que se ajuste a lo que quiero.
Se trata de sacar el porcentaje que representan cada cantidad de la columna TOTAL sobre un la suma total de esas misma columna (866.700), y que luego ese porcentaje sume el 100 %.
Utilizo la fórmula Redondear, y si muestro 2 decimales suma bien, pero si muestro 1 decimal la suma, aunque el resultado es 100%, cualquiera que lo sume a simple vista se dará cuenta de que no da 100%.
Lo que yo necesito es que se muestre la columna con 1 decimal y que la suma dé 100 %
Os pongo el ejemplo.

Las fórmulas que utilizo son:

=REDONDEAR((A1*100)/866700;2) - Para 2 decimales
=REDONDEAR((A1*100)/866700;1) - Para 1 decimal.

&&&&&&&&&&TOTAL&&&&&&2DECIMALES&&&&1DECIMAL
&&&&&&&&&&284.731&&&&&&32,85&&&&&&&&&&32,9
&&&&&&&&&&210.417&&&&&&24,28&&&&&&&&&&&24,3
&&&&&&&&&&188.736&&&&&&21,78&&&&&&&&&&&21,8
&&&&&&&&&&130.430&&&&&&15,05&&&&&&&&&&&15,1
&&&&&&&&&&&48.209&&&&&&&5,56&&&&&&&&&&&&5,6
&&&&&&&&&&&&4.177&&&&&&&0,48&&&&&&&&&&&&0,5
TOTAL.&&&&866.700&&&&&100,00&&&&&&&&&&100,0

(Jolin no sé quitar los &).
Fuerza y honor.
Saludos de Arturo desde Madrid
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5440
Enlace directo a este mensaje Enviado: 04/Octubre/2010 a las 15:26
1.- Selecciona los datos que has obtenido con 2 decimales.
2.- Botón secundario sobre la selección.
3.- Formato de celdas > Número > Número > Posiciones decimales: 1
4.- Pulsa Aceptar.
 
 
Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
arodrigu Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 04/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 565
Enlace directo a este mensaje Enviado: 04/Octubre/2010 a las 16:43
Hola AnSalVal:
Gracias por responder.
Tu solución es lo mismo que mi columna con el redondeo a 1 decimal, cuando sumas no da 100 da 102.
Fuerza y honor.
Saludos de Arturo desde Madrid
Arriba
arodrigu Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 04/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 565
Enlace directo a este mensaje Enviado: 04/Octubre/2010 a las 16:43
Perdón:
Da 100,2
Fuerza y honor.
Saludos de Arturo desde Madrid
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5440
Enlace directo a este mensaje Enviado: 04/Octubre/2010 a las 22:21
 

Pues NO debería.

 
Mi solución no hace ningún redondeo, ni  modifica los datos.

La modificación es solamente visual, y "detrás" siguen existiendo los datos como si tuvieran 2 decimales. Por lo tanto la suma debe dar 100 salvo que tengas ajustada Precisión de pantalla.

 
 
Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable