** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - restar fechas con formula SI
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradorestar fechas con formula SI

 Responder Responder
Autor
Mensaje
litris Ver desplegable
Habitual
Habitual
Avatar

Unido: 27/Noviembre/2006
Estado: Sin conexión
Puntos: 127
Enlace directo a este mensaje Tema: restar fechas con formula SI
    Enviado: 14/Julio/2017 a las 15:19
Buenas tardes,

A ver si me podeis ayudar a resolver esto.

Tengo 3 columnas: fecha creación, fecha incio, estado incidencia. Quiero crear otra columna en que  una de ellas que me diga el tiempo de respuesta (en minutos) desde que se crea la incidencia hasta que se empieza a hacer algo (fecha inicio). Estos campos de fecha tienen el formato de dd/mm/aaaa hh:mm:ss. Yo lo que he creado es lo siguiente para sacar el tiempo de respuesta -> =SI(B2="Pendiente";0;(C2-A2)*24*60)
He puesto una formula SI porque si la columna estado es diferente de Pendiente significa que habrá fecha de inicio. Si está en pediente es que no se ha hecho nada todavia por lo que no hay fecha inicio.
La fórmula solo me funciona bien si el campo estado incidencia es pendiente. Sino me da un resultado de -61434 (por ejemplo). Ya hago que la fecha de inicio esté por delante de la de creación para que no de un resultado negativo pero aún así lo hace.

No encuentro donde está el fallo.

Un saludo y gracias.
Ojos que no ven ostia que te metes
Arriba
lalo1956 Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 08/Marzo/2005
Localización: Mexico
Estado: Sin conexión
Puntos: 914
Enlace directo a este mensaje Enviado: 14/Julio/2017 a las 17:03
Hola!, en Office las fechas son números, independientemente de como quieras presentar la vista del formato.
Qué formato tiene la columna que quieres crear?
Creo que no debes multiplicar por 24 ni por 60, sino establecer el formato de hh.mm a la columna que piensas crear.
Espero haberme explicado bien, sino es así, seguro AnSanVal estará pronto por aquí, saludos!
Quien no vive para servir, no sirve para vivir!** AYUDA A MANTENER EL FORO **
Arriba
lalo1956 Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 08/Marzo/2005
Localización: Mexico
Estado: Sin conexión
Puntos: 914
Enlace directo a este mensaje Enviado: 14/Julio/2017 a las 19:16
Publicado originalmente por lalo1956 lalo1956 escribió:


Ejemplo de cómo lo haría yo

Formato Celdas Formato Celdas
dd/mm/aaaa hh:mm:ss Texto dd/mm/aaaa hh:mm:ss dd/mm/aaaa hh:mm:ss Num 8 Decim Texto Num 8 Decim Num 8 Decim
FechaCreacion EstadoIncidencia FechaInicio TiempoRespuestaMins FechaCreacion EstadoIncidencia FechaInicio TiempoRespuestaMins
01/07/2017 09:00:00   01/07/2017 09:30:00 00/01/1900 00:30:00 42,917.37500000 0 42,917.39583333 0.02083333
01/07/2017 09:00:00   02/07/2017 09:30:00 01/01/1900 00:30:00 42,917.37500000 0 42,918.39583333 1.02083333
01/07/2017 09:30:00   10/07/2017 09:35:00 09/01/1900 00:05:00 42,917.39583333 0 42,926.39930556 9.00347222
        0.00000000 0 0.00000000 0.00000000
        0.00000000 0 0.00000000 0.00000000
        0.00000000 0 0.00000000 0.00000000
        0.00000000 0 0.00000000 0.00000000
        0.00000000 0 0.00000000 0.00000000


Saludos!
Quien no vive para servir, no sirve para vivir!** AYUDA A MANTENER EL FORO **
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 4869
Enlace directo a este mensaje Enviado: 14/Julio/2017 a las 21:18
Cuando dices que lo quieres en minutos, ¿A que formato te refieres?

   horas y minutos   solo minutos
          0 h. 30 min.           30 min.
        24 h. 30 min.        1470 min.
      216 h. 05 min.      12965 min.




lalo 1956: «... seguro AnSanVal estará pronto por aquí...»

No necesariamente, es muy importante la participación variada, cuantos más mejor (es más rico el foro), aprendemos todos.

¡Gracias por tu participación! Es cierto que no es necesario multiplicar.


Pregunta lo que no sabes, recuérdalo para cuando te pregunten y ofrece tu ayuda (reconforta).

Mi sitio_web con ejemplos Excel.
Arriba
lalo1956 Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 08/Marzo/2005
Localización: Mexico
Estado: Sin conexión
Puntos: 914
Enlace directo a este mensaje Enviado: 14/Julio/2017 a las 21:37
Thumbs Up
Quien no vive para servir, no sirve para vivir!** AYUDA A MANTENER EL FORO **
Arriba
litris Ver desplegable
Habitual
Habitual
Avatar

Unido: 27/Noviembre/2006
Estado: Sin conexión
Puntos: 127
Enlace directo a este mensaje Enviado: 17/Julio/2017 a las 08:07
Gracias Lalo. Si te has explicado perfectamente. He cambiado el formato a hh:mm tal como comentais tu y AnSanVal.

También he encontrado el problema con las fechas que me daba en negativo. El encabezado está en la fila 1 y los datos están a partir de la fila 2. Cuando empezé a poner las formulas lo hice con SI(B2="Pendiente";0;(C2-A1)*24*60) y arrastré la formula para el resto de columnas. Por eso en algunos me daba el valor que parecia correcto pero en otros me salia negativo.

Finalmente ha quedado así la formula -> =SI(B2="Pendiente";0;C2-A2) y con la celda en formato hh:mm.

Muchas gracias por vuestra ayuda lalo1956 y AnSanVal.

Un saludo!
Ojos que no ven ostia que te metes
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable