** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - sumaproducto() combiando con funcion dia(
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradosumaproducto() combiando con funcion dia(

 Responder Responder
Autor
Mensaje
patroclo Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 10/Febrero/2005
Localización: España
Estado: Sin conexión
Puntos: 464
Enlace directo a este mensaje Tema: sumaproducto() combiando con funcion dia(
    Enviado: 09/Mayo/2011 a las 11:48
Hola a todos,
 
He hecho una formula que me debe sumar todos aquellos valores de la columnna AB si en la columna AA es el día 1 del mes, (en esta columna hay fechas que van del 1 al 31 del mes) y en la columna Z encuentrael nº 5.
 
La formula que utilizo es
 
=SUMAPRODUCTO((DIA($AA$7:$AA$1001)=1)*($Z$7:$Z$1001=5)*($AB$7:$AB$1001))
 
pero me suma 0.
 
Si hay algún problema de sintaxis, rogaría me lo indicarais.
 
Gracias
Mañana será mejor que hoy.
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5511
Enlace directo a este mensaje Enviado: 09/Mayo/2011 a las 15:31
La sintaxis es correcta, lo que no se es si las ordenes que le das coinciden con lo que quieres que haga. Inicialmente dices "... debe sumar todos aquellos valores de la columnna AB si en la columna AA es el día 1 del mes...", pero luego dices "... y en la columna Z encuentrael nº 5...". Para lo primero, en la fórmula sobra *($Z$7:$Z$1001=5), pero si quieres controlar tambien la columna Z, está todo correcto. 
 
 
Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
patroclo Ver desplegable
Asiduo
Asiduo
Avatar

Unido: 10/Febrero/2005
Localización: España
Estado: Sin conexión
Puntos: 464
Enlace directo a este mensaje Enviado: 09/Mayo/2011 a las 15:39
Hola,
 
Tienes razón es todo correcto, el problema ha sido no fijarme bien en los datos que me debía devolver, me salía 0 por que el día que le pedía no había coincidencias.
 
Gracias por todo.
 
Se puede cerrar el hilo.
 
 
Mañana será mejor que hoy.
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable