** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - sumar si o sumar si conjunto valores
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradosumar si o sumar si conjunto valores

 Responder Responder
Autor
Mensaje
GENARO1908 Ver desplegable
Nuevo
Nuevo


Unido: 27/Agosto/2006
Localización: España
Estado: Sin conexión
Puntos: 39
Enlace directo a este mensaje Tema: sumar si o sumar si conjunto valores
    Enviado: 08/Mayo/2021 a las 07:55
buenos dias,

me he trabado aqui para hacerlo en una sola formula, 

necesito como sumar del año 21 todo aquello que tanga un texto o valor en la columna explicacion

si hago esto me coje solo hola, pero no me coje ni " hola" ni 1

=+SUMAR.SI.CONJUNTO($D$3:$D$7;$C$3:$C$7;"2021";$F$3:$F$7;">""")


si hago esto =+SUMAR.SI.CONJUNTO($D$3:$D$7;$C$3:$C$7;"2021";$F$3:$F$7;"*")

no me coge 1... 

año cantidad concepto explic
2020 5 pan
2021 5 mantequilla
2021 5 pan 1
2021 5 pan  hola
2021 55 ajo hola
70 0 55


el resultado tiene q ser 65 :) 

grax
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5814
Enlace directo a este mensaje Enviado: 08/Mayo/2021 a las 12:08

El signo  +  como segundo carácter (aunque no afecta) ... ¿Para que lo agregas? ¿Para alargar algo la fórmula?


Prueba con:  =SUMAR.SI.CONJUNTO($D$3:$D$7;$C$3:$C$7;"2021";$F$3:$F$7;"<>")



Saludos desde Tenerife.

Mi sitio_web con ejemplos Excel.
Arriba
xavi Ver desplegable
Administrador
Administrador
Avatar
Terrassa-BCN

Unido: 10/Mayo/2005
Localización: Catalunya ||||
Estado: Sin conexión
Puntos: 13984
Enlace directo a este mensaje Enviado: 08/Mayo/2021 a las 14:53
El signo + después del = es la consecuencia de iniciar la formula con un + en lugar de un =.


Xavi, un minyó de Terrassa

Mi web
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5814
Enlace directo a este mensaje Enviado: 08/Mayo/2021 a las 20:25
Sí Xavi, lo sé (Excel añade el  =  en vez de sustituir), ocurre lo mismo si empiezas la fórmula con un  -  , pero en este caso está justificado ya que el valor es negativo y debemos expresarlo, pero en los valores positivos no es necesario incluirlo, y ya las fórmulas tienen sus problemas de interpretación para que además lo compliquemos innecesariamente.
→ Editado para sustituir 'negativos'  por  'positivos'.

Más bien creo que es consecuencia de algunos profesores que enseñan: «La fórmula se empieza con un + o un - y ...». 

Pero bueno, tampoco es tan importante como para «echar las campanas al vuelo». Wink  ¡Gracias!




Editado por AnSanVal - 08/Mayo/2021 a las 20:30
Saludos desde Tenerife.

Mi sitio_web con ejemplos Excel.
Arriba
GENARO1908 Ver desplegable
Nuevo
Nuevo


Unido: 27/Agosto/2006
Localización: España
Estado: Sin conexión
Puntos: 39
Enlace directo a este mensaje Enviado: 09/Mayo/2021 a las 08:24
hola,

muchas gracias, profesor profesor mas bien no, solo tuve un profesore durante una asignatura en la universidad alla por 1999... el tema del mas creo q es por sencillez durante los años, en el teclado si tengo q poner igual tengo q darle a dos teclas, si tengo q poner el mas solo a una... 
lo q me he dado cuenta q ahora si pongo el mas al inicio me añade el =, creo q en el pasado me dejaba empezar la formula solo por mas y habia diferencia en si empezaba por + o por =... en una te aparecia solo el resultado es decir si escribisa +35/5 solo te aparecia 7, y si ponias =35/5 te aparecia en la celda 7.... creo recrodar algo asi
a partir de ahora por vuestra recomendacion empezare toda las formulas por "="

retomando el tema de la formula gracias, les tendre q decir a los q meten mano al archivo q no dejen un espacio en blanco, pq si dejan un espacio en blanco solamente tb te recoge los datos.. el valor q yo busco es 87

alguna idea para q no te lo tome... 
años cantidad descripcion
2020 5
2020 11
2021 11   11 11 11
2021 17   17 17
2021 23 hola 23 23 23 23 23
2021 29 vale 29 29 29 29 29
2021 35 10 35 35 35 35
115 98 63 104 87
98 =SUMAR.SI.CONJUNTO($E$4:$E$10;D4:D10;"2021";$F$4:$F$10;"<>")
63 =SUMAR.SI.CONJUNTO($E$4:$E$10;D4:D10;"2021";$F$4:$F$10;"*")
115 =SUMAR.SI.CONJUNTO($E$4:$E$10;D4:D10;"2021";$F$4:$F$10;"<>""")
espacio vacio
2021 11
sin nada
2021 17
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5814
Enlace directo a este mensaje Enviado: 09/Mayo/2021 a las 18:46
Genaro1908.- «.. el valor q yo busco es 87».

- He copiado tus datos (tal cual) los he pegado en una hoja de Excel... y me da 87...


... no sé como lo haces para que te de 98. Ouch

Editado: en tu caso debes tener un texto (quizás un espacio) en F7.




Editado por AnSanVal - 09/Mayo/2021 a las 18:57
Saludos desde Tenerife.

Mi sitio_web con ejemplos Excel.
Arriba
GENARO1908 Ver desplegable
Nuevo
Nuevo


Unido: 27/Agosto/2006
Localización: España
Estado: Sin conexión
Puntos: 39
Enlace directo a este mensaje Enviado: 09/Mayo/2021 a las 19:38
hola buenas tardes,

si exactamente en el 2021 , el valor once hay un espacio vacio...
en el ejemplo real, es un archivo compartido, 10 personas meten mano en el archivo, con 150 filas, 6 columnas donde tienen q poner a mano una explicacion...

a veces aparece espacio vacio y la formula te da un resultado erroneo... 
 formula '=SUMAR.SI.CONJUNTO($E$4:$E$10;D4:D10;"2021";$F$4:$F$10;"<>")
te coge ese valor...

tendre q habilitar una hoja intermedia para q no me coja esa excepcion

muchas gracias 
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5814
Enlace directo a este mensaje Enviado: 10/Mayo/2021 a las 17:30
«... a veces aparece espacio vacío y la formula te da un resultado erróneo... »

Tú puedes seguir llamándolo como te guste, pero un espacio no es un espacio vacío, un espacio es el carácter 32, puede ser invisible pero no vacío y por tanto la fórmula devuelve el resultado que debe devolver, aunque no sea lo que tú necesitas (la celda NO está vacía).


Saludos desde Tenerife.

Mi sitio_web con ejemplos Excel.
Arriba
GENARO1908 Ver desplegable
Nuevo
Nuevo


Unido: 27/Agosto/2006
Localización: España
Estado: Sin conexión
Puntos: 39
Enlace directo a este mensaje Enviado: 10/Mayo/2021 a las 18:18
todo depende de qn lo mire,

si lo mira un informatico o un ingeniero, esta claro q es como tu dices... Si lo mira alguien con perspectiva economica ve un espacio como algo vacio sin valor :) o al menos es lo que yo veo....

muchas gracias , insistire en este matiz para q no se cuelen 

como siempre aprendiendo del maestro Ansalval :) 
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5814
Enlace directo a este mensaje Enviado: 10/Mayo/2021 a las 18:24

Creo que combinando ESPACIOS y LARGO...

=SUMAPRODUCTO(($D$4:$D$9=2021)*(LARGO(ESPACIOS($F$4:$F$9))>0)*($E$4:$E$9))

... podemos obtener lo que buscas.


Saludos desde Tenerife.

Mi sitio_web con ejemplos Excel.
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5814
Enlace directo a este mensaje Enviado: 10/Mayo/2021 a las 18:43
«... Si lo mira alguien con perspectiva económica ve un espacio como algo vacío sin valor...»

Yo (no soy informático ni economista Embarrassed y menos 'maestro', pero ¡Gracias!):
Casimiro → aquí veo un nombre.
Casi miro → aquí estuve a punto de mirar (la diferencia es un espacio... ¿vacío?).
qso → aquí NO veo un queso (posiblemente tú sí), como tú dices «Depende de quien lo mire».  Wink


Saludos desde Tenerife.

Mi sitio_web con ejemplos Excel.
Arriba
GENARO1908 Ver desplegable
Nuevo
Nuevo


Unido: 27/Agosto/2006
Localización: España
Estado: Sin conexión
Puntos: 39
Enlace directo a este mensaje Enviado: 15/Mayo/2021 a las 07:44
Muchas graX Maestro.. :) Funciona, el sumaproducto tb lo usaba antes del sumar.si.conjunto... formula extraña pero funcionaba... 


Editado por GENARO1908 - 15/Mayo/2021 a las 07:46
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable