** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - Establecer recargo de forma automática
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoEstablecer recargo de forma automática

 Responder Responder
Autor
Mensaje Invertir el orden de clasificación
korea2007 Ver desplegable
Nuevo
Nuevo


Unido: 25/Marzo/2007
Localización: España
Estado: Sin conexión
Puntos: 0
Enlace directo a este mensaje Tema: Establecer recargo de forma automática
    Enviado: 18/Agosto/2010 a las 17:32
Hola AnSanVal gracias por contestar.
 
Efectivamente si aplicamos el porcentaje a la suma de las cantidades en vez de directamente a la celda del pendiente, funciona perfectamente.
 
La fórmula de la celda B quedaría así:
 
=SI(HOY()>FECHANUMERO("12-8-2010");(A2-C2)*0,1;0)
 
Por mí se puede cerrar el hilo
 
Gracias de nuevo y un saludo
Arriba
AnSanVal Ver desplegable
Administrador
Administrador
Avatar

Unido: 16/Marzo/2005
Localización: España
Estado: Sin conexión
Puntos: 5511
Enlace directo a este mensaje Enviado: 18/Agosto/2010 a las 13:09
 

Es lógico que así sea.

 
Supuesto:

En B3 escribe el 10% de D3 (90) =  9, con lo que D3 pasa a valer 99, pero como B3 debe contener el 10% de D3, escribe en B3 9,9, con lo que D3 pasa a valer 108,9, debido a esto B3 debe actualizar a "su nuevo 10%", que será 10,89 por lo que D3 pasa a valer 119,79, por lo que B3...  :-(   ...  ¿Cuando pararíamos?

 
Lo lógico es que apliques el 10% p.e. a la cuota, o a la cuota menos lo entregado, o... etc. pero no que B dependa de D y D dependa de B.

Aprendemos viendo respuestas de otros, también intentando resolver dudas (intenta ayudar cuando puedas/sepas).

Mi sitio_web con ejemplos Excel.
Arriba
korea2007 Ver desplegable
Nuevo
Nuevo


Unido: 25/Marzo/2007
Localización: España
Estado: Sin conexión
Puntos: 0
Enlace directo a este mensaje Enviado: 18/Agosto/2010 a las 12:11
Hola a todos
 
Se trata de lo siguiente. Tengo una tabla para llevar las cuentas de los propietarios tal que así:
 
A                      B                    C                       D
Cuota             Recargo          Entregado        Pendiente
90                   0                     90                     0
90                   0                       0                      90
 
En la columna D tengo la siguiente fórmula: =A2+B2-C2
 
El recargo se aplica a los propietarios que excedan de una determinada fecha sin haber pagado y es de un 10% del saldo pendiente . Lo que quiero es que al pasar de esa fecha, en la casilla B aparezca ese recargo y la casilla D quede actualizada con el nuevo saldo pendiente.
 
Para ello he insertado la siguiente fórmula en la casilla B: =SI(HOY()>FECHANUMERO("12-8-2010");D2*0,1;0)
 
El problema es que me da error de referencia circular porque para calcular el recargo tiene que utilizar esta misma celda para el cálculo del pendiente, y por más vueltas que le doy no se como solucionarlo.
 
Agradecería una ayuda para ello o bien mediante un fórmula o mediante VB.
 
Gracias y a todos y un saludo.
 
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable