** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - formula para buscar por fila y columna en
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoformula para buscar por fila y columna en

 Responder Responder
Autor
Mensaje
maruja Ver desplegable
Asiduo
Asiduo


Unido: 02/Julio/2008
Estado: Sin conexión
Puntos: 418
Enlace directo a este mensaje Tema: formula para buscar por fila y columna en
    Enviado: 14/Marzo/2012 a las 18:22
hola
Tengo una matriz, con rótulos de fila peso y de columna localidades con distintos valores en la matriz y una tabla en la que en cada fila tengo un peso y una localidad y tengo que buscar el valor que corresponda en la intersección de la matriz, ¿Qué formulas uso?

gracias

Arriba
Jordi-Albert Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 06/Abril/2006
Localización: Alemania
Estado: Sin conexión
Puntos: 4321
Enlace directo a este mensaje Enviado: 14/Marzo/2012 a las 20:04
BuscarV ????

=buscarV(valorABuscar; matriz ; columna_devolver)

Nota: Jordi-Albert es, todo él, un nombre. Mi nombre
Arriba
maruja Ver desplegable
Asiduo
Asiduo


Unido: 02/Julio/2008
Estado: Sin conexión
Puntos: 418
Enlace directo a este mensaje Enviado: 15/Marzo/2012 a las 08:07
no,
 
porque tengo que buscar el valor exacto de un buscarv y un buscarh pero a la vez.... me explico?
 
gracias
Arriba
Jordi-Albert Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 06/Abril/2006
Localización: Alemania
Estado: Sin conexión
Puntos: 4321
Enlace directo a este mensaje Enviado: 15/Marzo/2012 a las 12:43
=buscarV(valorABuscar; matriz ; buscarH(valor2; matriz2 ; 1) )
????????
Nota: Jordi-Albert es, todo él, un nombre. Mi nombre
Arriba
maruja Ver desplegable
Asiduo
Asiduo


Unido: 02/Julio/2008
Estado: Sin conexión
Puntos: 418
Enlace directo a este mensaje Enviado: 15/Marzo/2012 a las 20:35
me da error ¡ref!
Esa función no vale, porque el buscarh me devuelve un valor de la matriz, y lo que necesito para que funcione es que devuelva un número de fila.


No se si me he explicado bien, o es que no se puede hacer, tengo una matriz, y con dos valores a buscar (primera fila y primera columna de la matriz) y quiero que me devuelva el valor de la matriz de la intersección del valor de la fila y la columna a buscar.
muchas gracias
Arriba
oirausu Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 25/Diciembre/2005
Localización: España
Estado: Sin conexión
Puntos: 4217
Enlace directo a este mensaje Enviado: 15/Marzo/2012 a las 21:03

Buscar te devuelve la posicion de un valor en una matriz, puedes usarlo para buscarlo en la fila o columna de encabezados y luego usar ese valor para pedir la fila que uscarV o buscarH te tiene que devolver

 
algo asi como
 
BuscarV(valor1;matriz;Buscar(valor2;filaencabezados;valor2))
Arriba
Jordi-Albert Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 06/Abril/2006
Localización: Alemania
Estado: Sin conexión
Puntos: 4321
Enlace directo a este mensaje Enviado: 15/Marzo/2012 a las 23:54

suponiendo una matriz del tipo
---- col1 -- col2 -- col3 -- col4
row1
row2
row3

simplemente añade una fila para que tengas esta estructura

---- col1 -- col2 -- col3 -- col4
----    1 --   2 --   3 -- 4
row1
row2
row3

ahora el BuscarH puede devolver el "valor" de la columna deseada

Editado por Jordi-Albert - 15/Marzo/2012 a las 23:56
Nota: Jordi-Albert es, todo él, un nombre. Mi nombre
Arriba
sailepaty Ver desplegable
Asiduo
Asiduo


Unido: 23/Junio/2006
Localización: Estados Unidos
Estado: Sin conexión
Puntos: 458
Enlace directo a este mensaje Enviado: 16/Marzo/2012 a las 01:05
Digamos que tus datos están en el rango A1:F30, donde la columna A tiene los valores a buscar verticalmente y la fila 1 tiene los valores a buscar horizontalmente.
 
=INDICE(A1:F30;COINCIDIR(Valor_V;A1:A30;0);COINCIDIR(Valor_H;A1:F1;0))
 
Saludos
Arriba
oirausu Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 25/Diciembre/2005
Localización: España
Estado: Sin conexión
Puntos: 4217
Enlace directo a este mensaje Enviado: 16/Marzo/2012 a las 22:57

Disculpa mi anterior respuesta, hace tiempo que no uso excel y me despiste

 
Mi propuesta es similar a la de sailepaty
 
=DESREF(A1;COINCIDIR(D13;A2:A5;0);COINCIDIR(E12;B1:E1;0))
 
suponiendo que tienes la matriz a partir de A1, y los valores buscados de fila y columna en D13 y E12
Arriba
maruja Ver desplegable
Asiduo
Asiduo


Unido: 02/Julio/2008
Estado: Sin conexión
Puntos: 418
Enlace directo a este mensaje Enviado: 20/Marzo/2012 a las 13:27
hola,
he usado esta formula, peor el tipo de coincidencia en la formula coincidir he puesto -1 para que me coga el valor mayor y asi no me funciona.
=INDICE('[TARIFA CON CODIGO.xlsx]Hoja1'!$A$5:$AG$78;COINCIDIR(E2;'[TARIFA CON CODIGO.xlsx]Hoja1'!$A$5:$A$77;0);COINCIDIR(H2;'[TARIFA CON CODIGO.xlsx]Hoja1'!$A$5:$AG$5;-1))
alguna idea
gracias
Arriba
maruja Ver desplegable
Asiduo
Asiduo


Unido: 02/Julio/2008
Estado: Sin conexión
Puntos: 418
Enlace directo a este mensaje Enviado: 21/Marzo/2012 a las 17:04
gracias, ya está solucionado, es que para poner -1 el valor max tiene que estar ordenado en orden descendente.
se puede cerrar el hilo


Editado por maruja - 21/Marzo/2012 a las 17:04
Arriba
Peluchon Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 17/Noviembre/2006
Localización: España
Estado: Sin conexión
Puntos: 41
Enlace directo a este mensaje Enviado: 22/Marzo/2012 a las 16:26
Porqué no usas sumaproducto() ?
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable