** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Otros de Microsoft: Windows y Office > Excel
  Mensajes nuevos Mensajes nuevos RSS - Condicional hombre/mujer
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoCondicional hombre/mujer

 Responder Responder
Autor
Mensaje
daganji Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 26/Febrero/2008
Localización: España
Estado: Sin conexión
Puntos: 14
Enlace directo a este mensaje Tema: Condicional hombre/mujer
    Enviado: 05/Abril/2012 a las 10:52
Buenos días.
 
Tengo esta tabla:
 

 

B

C

U

V

W

Y

 

NOMBRE 

SEXO

PRUEBA 1

PRUEBA 2

PRUEBA 3

RESULTADO

3

PEPE

HOMBRE

APTO

APTO

APTO

APTO

4

JUAN

HOMBRE

APTO

NO APTO

APTO

NO APTO

5

ROSA

MUJER

APTO

APTO

APTO

APTO

 
en la columna Y, me da el resultado de APTO ó NO APTO, si las tres pruebas son APTAS, y en el caso que una de ellas fuese NO APTO, ya me daría NO APTO, después de aplicar la siguiente fórmula:
 
=SI(Y(U3="apto";V3="APTO";W3="APTO");"APTO";"NO APTO").
 
Mi Pregunta es la siguiente:
 
1º Como veis en la columna C, está el sexo, quisiera que dependiendo de ello, el resultado fuese apto o apta, no apto o no apta, tanto en cada una de las pruebas, como en el resultado final.
 
Muchas gracias
 
 
 
 


Editado por daganji - 05/Abril/2012 a las 10:54
Arriba
Jordi-Albert Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 06/Abril/2006
Localización: Alemania
Estado: Sin conexión
Puntos: 4317
Enlace directo a este mensaje Enviado: 05/Abril/2012 a las 11:33
suponiendo que APTO/APTA de la columna U tiene la terminacion correcta, puedes usar la siguiente formula

=SI(LARGO(U3&V3&W3)=12; DERECHA(U3;4); "No " & DERECHA(U3;4))

es decir, creo una cadena con el resultado de "AptoAptoApto" y si no da 12 significa que hay algun "NO", pòr lo que el resultado es "NO" + las 4 ultimas letras del valor de U3

espero que no tengas problemas al respecto



Editado por Jordi-Albert - 05/Abril/2012 a las 11:41
Nota: Jordi-Albert es, todo él, un nombre. Mi nombre
Arriba
Jordi-Albert Ver desplegable
Colaborador
Colaborador
Avatar

Unido: 06/Abril/2006
Localización: Alemania
Estado: Sin conexión
Puntos: 4317
Enlace directo a este mensaje Enviado: 05/Abril/2012 a las 11:38
en caso de que no lo puedas saber, podrias hacer

=SI(LARGO(U3&V3&W3)=12; ""; "No ") & "Apt" & SI(MAYUSC(C3)="HOMBRE"; "o";"a")


Editado por Jordi-Albert - 05/Abril/2012 a las 11:41
Nota: Jordi-Albert es, todo él, un nombre. Mi nombre
Arriba
daganji Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 26/Febrero/2008
Localización: España
Estado: Sin conexión
Puntos: 14
Enlace directo a este mensaje Enviado: 05/Abril/2012 a las 12:26

Muchas gracias Jordi, sobre todo por tu pronta respuesta y sabiduría.

 
La segunda opción que me has puesto me funciona correctamente.
 
=SI(LARGO(U3&V3&W3)=12; ""; "No ") & "Apt" & SI(MAYUSC(C3)="HOMBRE"; "o";"a")
 
Puedes cerrar el hilo.


Editado por daganji - 05/Abril/2012 a las 12:27
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable