** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - Uso TempVars macro
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Tema cerradoUso TempVars macro

 Responder Responder
Autor
Mensaje
Yotagril Ver desplegable
Habitual
Habitual


Unido: 02/Diciembre/2011
Estado: Sin conexión
Puntos: 131
Enlace directo a este mensaje Tema: Uso TempVars macro
    Enviado: 12/Mayo/2015 a las 17:13
Cordial saludo,
Uso Access 2010, con mi propia barra, y las macros para "lanzar" los formularios.
Tengo un formulario que me sirve para diferentes casos, que manejo en el código "TempVars!apl", y defino apl en la macro con su valor según sea el caso y luego AbrirFormulario.
El problema es que si ejecuto uno de estas opciones como primera acción me genera un error 2046 para la macro, el mensaje es "La acción o comando 'DefinirVariableTemporal' no esta disponible".
Si he "abierto" antes otro formulario, el error no aparece. He tratado en esa opción de abrir oculto otro formulario para simularlo, pero no vale.
De antemano gracias por los comentarios.
Arriba
mounir Ver desplegable
Colaborador
Colaborador


Unido: 09/Febrero/2009
Localización: Asturias-España
Estado: Sin conexión
Puntos: 5755
Enlace directo a este mensaje Enviado: 12/Mayo/2015 a las 20:39
Hola!

¿Tienes la ventana de base de datos Oculta?
Un Saludo.
Arriba
Yotagril Ver desplegable
Habitual
Habitual


Unido: 02/Diciembre/2011
Estado: Sin conexión
Puntos: 131
Enlace directo a este mensaje Enviado: 12/Mayo/2015 a las 22:52
Si, esta oculta.
Arriba
mounir Ver desplegable
Colaborador
Colaborador


Unido: 09/Febrero/2009
Localización: Asturias-España
Estado: Sin conexión
Puntos: 5755
Enlace directo a este mensaje Enviado: 12/Mayo/2015 a las 23:04
Hola!

Es por eso, mírate este enlace lo que dice Microsoft y las soluciones que aporta.

https://support.microsoft.com/en-us/kb/244695/es



Mucha suerte!!!
Un Saludo.
Arriba
Yotagril Ver desplegable
Habitual
Habitual


Unido: 02/Diciembre/2011
Estado: Sin conexión
Puntos: 131
Enlace directo a este mensaje Enviado: 13/Mayo/2015 a las 16:55
Gracias mounir por tu colaboración. El error no me aparece al abrir el formulario sino en la definición de la variable "TempVars". En las demás opciones que no uso "TempVars" todo va bien.
De momento he resuelto abriendo siempre de inicio un formulario de introducción algo así como un "acerca de" y funciona.

Aunque me quedo con la duda del correcto uso y funcionamiento de "TempVars" puedo pasarlo por alto (con este "truco"), hasta otro momento.

Gracias, si gustan pueden cerrar el hilo.
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable